Could not export dashboard

Philipp U. shared this problem 5 months ago
Resolved

Hi, I'm trying to export a dashboard and I am getting this error:

/58ab652af107d013892dd445b1629dd9


I saw: https://community.yellowfinbi.com/topic/could-not-find-the-report-with-id-93254-error-when-exporting

I have no access to the configuration database. Is there another way I can get around this? Using Yellowfin 9.4.2


Many thanks,

Philipp

Best Answer
photo

Hi Mike,


Thanks for the reply.


I found the cause of the issue: if you add a co-display item to a report then delete that co-displayed item this will happen.


I am now having this issue when trying to import the file:

/a0239af86f9b089c6777742b836697f4

Should I open a new ticket?

Comments (6)

photo
1

Hi Philipp,

Thanks for reaching out. Unfortunately, this error means there's a "bad" report record attached to this particular dashboard. I'm afraid there's no simple way to address this via the UI. Technically, you could open this particular Dashboard and try removing reports one-by-one, re-attempting export each time until one of them works, but it would certainly be simpler to have a DBA just search for ReportId '212327' in the ReportHeader table to just tell you what report is triggering the problem.

Please let me know if you have any other questions on this.

Regards,

Mike

photo
1

Hi Mike,


Thanks for the reply. Is there any reason why a "bad" report could happen, so I can avoid this in the future?

photo
1

Hi Philipp,

Unfortunately, without a replication there's really no way of saying how it got to that state, only that it did. This isn't a common occurrence, so hopefully it's just a fluke that this occurred in the first place. If you do come across this issue again, then please let us know steps that were taken prior to the issue re-occurring and we should be able to dig deeper on it.

Regards,

Mike

photo
1

Hi Mike,


Thanks for the reply.


I found the cause of the issue: if you add a co-display item to a report then delete that co-displayed item this will happen.


I am now having this issue when trying to import the file:

/a0239af86f9b089c6777742b836697f4

Should I open a new ticket?

photo
1

Hi Philipp,

Sorry, I thought I replied to this earlier. Thanks for confirming. I see you submitted a new ticket, which is good because it seems to be unrelated to what this issue was.

The only extra recommendation here is to re-replicate the issue where you get to the error, take note of the timestamp, then subsequently provide said timestamp, along with a compressed copy of your entire logs folder, located at <YellowfinInstall>/appserver/logs so we can investigate further. There should be further indication in there as to what's occurring behind the scenes. I will leave that ticket unassigned though for someone closer to your timezone to pickup to expedite troubleshooting, but I will throw in the same response there

Please let me know if you have any other questions on this dashboard export issue.

Regards,

Mike

photo
1

Hi Philipp,

I'm going to go ahead and mark this one as Resolved to troubleshoot the separate issue in the other ticket, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike