Conditional Formatting in embedded content not working

Paul Nichols shared this problem 10 months ago
Awaiting Reply

Hi,

We have a variety of reports that are embedded into our intranet site using the JavaScript API, with some containing conditional formatting. Following the upgrade to 7.3+ any condition formatting that uses icons is not being displayed in the embedded report (it is also not displaying in Word exports).

If the conditional formatting is changed to a cell based rule rather than an icon rule it does work.

I have tried removing and adding again the conditional formatting but this also has not worked.

The difference can be seen in the attached screen shots.


Cheers

Paul

Comments (34)

photo
1

Hi Paul,

Thanks for your email.

Can you please give me bit more information such as, Version and Build of older and the new of Yellowfin?

So that , I can create some conditional format and update to replicate the issue and escalate to developers.

Let me know if you have any questions.

Regards,

Mahe

photo
1

Hi Mahe,

The current code version is 20170920 / 7.3+, I don't know what build we were on before but it was V7.2 and it also worked in V7.1.

Cheers

Paul

photo
1

Hi Paul,

In the Yellowfin folder you will have a file called patchlog, you will find the older version and build in the latest patchlog file.

Regards,

Mahe

photo
1

Hi Mahe,

I don't have access to any application files or folders. However as mentioned it has always previously worked in several version of 7.1 and 7.2.

photo
1

Hi Paul,

I have replicated the issue and going to raise a defect to the developers.

In the mean time, please let me know if you have any questions,

Regards,

Mahe

photo
2

Hi Paul,

Here is the Defect ID: 7993.

I have raised defect, and doesn't have any ETA at the moment.

I will update you once I get an update about this ticket.

Regards,

Mahe

photo
1

Hi I'm having the same problem in the embedded reports, also in missing in the broadcast reports. This is happening after upgrading to the latest version.

photo
1

Hi Elisa,

This defect hasn't been fixed yet.

And sorry, I don't have any ETA at this stage.

I will update the Defect ticket, that the issue is now in the broadcasts reports as well.

Can you please let me know the version and build you have upgraded to?

Let me know if I can help with anything else.

Regards,

Mahesh

photo
1

Yellowfin 7.4, March 13

photo
1

Thanks Elisa. I have updated the defect ticket.

I will keep you posted.

Regards,

Mahesh

photo
1

Hello! Any progress on solution or at least a suggested workaround on this issue?

photo
photo
1

Hi Elisa,

Thanks for reaching us. Sorry there is no update yet on this ticket.

I will update you once I hear from dev's on this issue.

Please let me know if I can help you with anything else.

Regards,

Mahesh

photo
1

Hello! Any progress on solution or at least a suggested workaround on this issue? We are here severely affected by this bug. We depend on embedding. Please let me know how I can raise the severity of this issue.

photo
1

Hi Elisa,

Apologies for delay, I was trying to chase up with developers.

Sorry to say but this issue is not picked up by developers. I learnt that the traffic lights are not going to come back due to changes in the architecture.

We got a workaround for this issue, so now instead of using Traffic Lights option, you may choose other Icons from the list and choose the desired colour by adding conditions.

This may looks like this:

31ec33e0ba321f7e7b1222d4353e2041

I have attached a quick video.

Please let me know if you have any questions or any issues using this option.

Regards,

Mahesh

photo
1

Hi Mathe, thanks for your effort in the workaround provided, but it still not solve the issue of embedding the report or broadcast.

My license is based on multicast so I loose a lot of functionality with this bug.

photo
1

Hi Elisa,


Pretty sure we have a way to sort this out, though it looks like it requires a licence (which should be free) from Awesome Fonts.

Just trying to work out the logistics before we send across a way for you to call this in your .JSP.

I'll give you a call tomorrow on this, as I want to ensure I understand your solution needs (I'm based in Melbourne, so will be your afternoon)


Thanks,

David

photo
1

Hi Elisa,


I tried giving you a call, and left a message on your machine.

Please let me know a good time to call, and we can organise a quick chat.


Thanks,

David

photo
1

Thanks for calling and apologies for not being at the office. Let me try the proposed solution and I will give you feedback as soon as possible.

photo
1

Thanks Elisa, how did it go?

photo
1

Hi David, I work with Elisa, id like to work this issue with you, you can call the same number and ask for Roberto Durand. We can schedule it outside of our office hours to meet your time if needed. Thanks!

photo
1

Hi Roberto, I called but the person I spoke to does not speak English.

Can you please provide your direct number I can reach you on?

Alternatively give use a call over in Australia +61 3 8593 8905


Thanks,

David

photo
1

Hi David, sorry about that, my extension is 1014.

photo
1

Hi Roberto, so we don't play phone tag I'm going to pass this across to the US office.

Thanks,

David

photo
1

Hi David, can you send me the instructions to have this implemented? If you need to call we can schedule a date so we dont miss the call. Appreciate your time and effort.

photo
photo
1

Hi Roberto,

Do you have a few minutes to screen-share on this at any point in the next couple of days? Please let me know what works best for you I am on US MST.

Nathan

photo
1

Hi Nathan, I am available at 9:00am (MST) or between 1:00pm - 3:00pm (MST), we can schedule for today or any day this week.

photo
1

Hi Roberto,

Can we plan on a screenshare at 1pm MST (20 min from now)?

Nathan

photo
1

Hi Nathan, Yes i am available.

photo
1

Hi, if you need to reschedule let me know, my number is 7878341000

email: roberto.durand@cerveceradepr.com

photo
1

Hi Roberto,

Yes I am sorry something came up. I will pass along a link shortly and you can join whenever you are ready.

Nathan

photo
1

Here is a link we can use:

https://meetings.ringcentral.com/j/1485276046

Nathan

photo
photo
1

Hi Roberto,

Per our conversation I am going to set this back to defect logged, and will update you as soon as action is taken to fix this permanently.

Let me know if you have any questions in the meantime!

Regards,

Nathan

photo
1

Hi Nathan, thank you for your time today, I forgot to ask you if we could apply the workaround on the broadcasted reports sent via email.

photo
1

Unfortunately it will not be possible to transfer this over to broadcasts as we do not have any external control over the content set here. You might have more luck with pdf exports than html though.


Nathan

photo