Chart doesn't appear on export to PDF

Prishan Fernando shared this problem 2 years ago
Resolved

Hi,


It seems like when exporting a report to PDF the chart doesn't appear on the export. This happens only if the Table is off (hidden) and the orientation of the PDF is set to landscape. Can you please check this.


We are using version 7.1 build 20160728.


Cheers

Prishan

Comments (4)

photo
1

Hi Prishan,


well, I've got bad and good news...the bad news is that 7.1 basic support (monthly patches) is being stopped from December 2016 and the extended support (critical issues) – from August 2017, and I'm afraid that the issue you have described can't be deemed a critical one.


However, the good news is that I have tested for this issue in the latest build of 7.2 and it is not there! I turned the table off in a table & chart report, set the PDF orientation to landscape then did the export and the chart was present in the resulting PDF file. I have recorded this test on the attached video for your perusal.


So, when you upgrade to 7.2, which you will have to do soon, you will find the issue resolved!


regards,

David

photo
1

Thanks David, infact we're planning to upgrade to 7.2 somewhere soon. Thanks for confirming that this is not found in 7.2


Cheers

Prishan

photo
1

Hi Prishan,


please ignore this...I'm just adding a comment so that you're not the last commenter (if you're the last one then the ticket stays on my work list)


regards,


David

photo
1

Actually, I'm on 7.3 and while using the same export settings I encountered the same issues. The difference is, my charts weren't showing up at all in landscape and I was missing one chart in portrait mode. It became quite clear to me that my charts were probably getting cutoff. My canvas size was 845 x 1215 and this is why export didn't like PDF landscape. I was able to fix this issue on my own by changing the size of my canvas. I changed my canvas to 845 x 1000 and landscape still doesn't work but portrait and letter size works fine. The one that wasn't displaying was right between 900 and 1215. The paper size was 'letter' so that was that. I believe that if this issue is still occurring for anyone then they need to check their canvas size and make sure that the size of the canvas is not out of the scope of the page orientation.