Calculated field error: For input string: ""

Siim Neljandik shared this problem 2 weeks ago
Awaiting Reply

Hello,


In one report I am getting the For input string: "" error when I try to create a calculated field. I am not getting that error in other reports with the same or different view.


Application Version:7.4.10

Build:20190510


All the best

Siim N

Comments (5)

photo
1

Hello Siim,

Thanks for reaching out with this issue.

Does this issue persist with other SQL queries? Or is this only present with the shown example?

Please let me know.

Thanks,

Jared

photo
1

Hello, the issue was with all calculated fields. I used this as an example because this eliminates the possibility of the problem being in the fields/calculations used.

photo
photo
1

Hello Siim,

Does this issue remain if you re-create this single report?

If so, it should be helpful to my replication of this if you provided screenshots of your entire report builder.

Thanks,

Jared

photo
1

Hello,


Sorry for the long response. The issue seemed to be because of another calculated field. This report was exported/imported between client organisations without errors, but one of the calculated fields broke during that process. It was a leftover days between predefined calculated field and one of the fields used in the calculation was missing. Because of that the report itself worked fine, but for some reason it was stopping any other calculated field editing without giving a meaningful error message.


All the best

Siim N

photo
1

Hello Siim,

Thanks for the update.

Glad to hear that you found the root cause of this issue. With that information, were you able to resolve this issue?


Please let me know. If this issue is resolved please let me know if you think its appropriate to mark this ticket as complete.

Thanks,

Jared

photo