Access filters are not working with View Caching

Pratap Singh shared this problem 10 months ago
Defect Logged

Hi

Access filters are not working with View Caching, when trying to apply access filters at the report, report throws error showing SQL syntax error. here possible case can be Different column names at View and Table Created for Caching.

Regards

Pratap

Comments (11)

photo
1

Hi Pratap,

Thanks for reaching out. It is indeed a possibility that a difference in column names between the two could cause an issue here. Can you replicate and send a compressed copy of your entire logs folder, located at <YellowfinInstall>/appserver/logs ? Logs usually give some sort of indication what's going on with cached filters.

Thanks,

Mike

photo
1

Hi Mike,

I am unable to send Log files through hostedftp as it is showing Quata Restriction error, is there any other way to share logs privately ?

Regards

Pratap

photo
1

Hi Pratap,

You should be able to attach them right here in the community. Please let me know if you have issues doing so.

Thanks,

Mike

photo
1

Hi,

Here I have attached log files and example report.

Regards

Pratap

photo
1

Hi Pratap,

It seems the issue here could be that the following data source is being marked as unavailable: Source 112.196.94.137-posresttestcopy. Can you head into your Admin Console > Data Sources > click into corresponding data source > and under Connection Settings, click Test Connection? There's 1682 mentions of this error in the logs file, so it looks like that data source may be completely unavailable.

Regards,

Mike

photo
1

Hi Mike,

Yes, this data source is unavailable but I am not using this data source for any report. I have simply removed the data source. and for this report, I am using a separate data source which has other reports working. the same report also works when unchecking data source at the report level.

regards

Pratap

photo
1

Hi Pratap,

I'm a bit confused by your response. Are you saying that now that you've removed the data source the report is working?

If this is the only report this is occurring with, can you try creating a copy of the report and seeing whether the issue still occurs?

Thanks,

Mike

photo
1

Hi Mike,

Seems that things are mixed up. the data source you were talking about (Which was showing error in log), I was not using that at all. so I simply deleted that data source. the report was on the different data source on same yellowfin instance. Let me explain the issue again with steps to reproduce at your end.

1. Create a data source with an access filter.

2. create view and Cache that view.

3. create the report based on that view and apply access filter for the report.

4. run the report and you will get an error in your report.

Here I have attached an image for more explanation.

Regards

Pratap

photo
photo
1

Hi Pratap,

Thank you for giving me these detailed replication steps. With this, I am now able to replicate what you're seeing. The error message I'm seeing corresponds with yours in the logs folder as well:

Your error message:

/tAN6MYCjVvAAAAAASUVORK5CYII=

My error message:

/D91K5zB0Mg4AAAAAAElFTkSuQmCC

In fact, if I have view caching enabled and try using the Access Filter, reports built off the view stop working entirely - I can't drag and drop any fields with or without the access filter on. Unfortunately, I can't see a way around this behavior, aside from not using View Caching.

I've gone ahead and submitted a defect for this and any potential updates regarding this will be posted here.

Regards,

Mike

photo
1

Thanks, Mike.

photo
1

Hi Pratap,

You're welcome. I'll keep you posted.

Regards,

Mike

photo