Data source unavailable for 1 user

Khushboo Khaitan shared this question 7 months ago
Completed

Hi

One of the data sources for YellowFin always shows as unavailable for me, and I'm an admin.

Until someone else (even someone without admin privileges) goes in to run a report that uses that data source. Then it starts working for me again - for a little bit.

This cycle has been going on for a while now, so appreciate if there's anything we can do for this.

Thanks!

Replies (1)

photo
1

Hello Khushboo,

Thank you for reaching out to Yellowfin Support

I would like to know the following information to look into this further.

1. Could you please share the info.jsp, to access this page, just append info.jsp to your YF url.

E.g. http://localhost:8080/info.jsp

2. Is this the first time it's happening? Was this working correctly before?

3. Any changes or modification done?

4. Is this an upgrade-related issue?

5. Additionally, could you check the connection pools settings.

0304b15f435f6771a63dc84aba0b1fc9

Try increasing the timeout and maximum connections limit.

5. After doing this could you please try creating the data source one more time from scratch and let me know if that works.


Regards,

Yamini Naidu

photo
1

Hi Yamini

Thanks for your reply. My replies below:

1. Attached

2. It was working fine until a couple weeks ago. Since then I get this intermittent issue while the other users of YellowFin don't.

3. No

4. No

5. Already increased, pls refer to screenshot attached.

6. I've already tried creating the data source from scratch in a separate tenant and that new tenant has the same issues.

photo
1

Hello Khushboo,

Thanks for your prompt response

I appreciate you shared all the details. Allow me some time to look into this, I'll get back to you with my findings.

Regards,

Yamini Naidu

photo
1

Hello Khushboo,

Could you please try the below setting in database level.

INSERT INTO Configuration VALUES (1, 'SYSTEM', 'NEVERMARKSOURCEUNAVAILABLE', 'true');

By inserting the above, the data source will never be flagged as unavailable. This means even if the data source connection cannot be made during connection pool creation, it will still be available for future connection attempts, without needing to manually test the data source or web services.

Link for reference: https://wiki.yellowfinbi.com/display/yfcurrent/Advanced+Configurations#AdvancedConfigurations-Preventdatasourcesfrombeingflaggedas"unavailable"evenwhenoffline

Additionally, if issue persist could you share the debug logs in the ftp link below. In the ftp link provided below, you can share any files or folders. By selecting the upload file option on the ftp link, you can upload the file without logging in.

https://ftp.yellowfin.bi/login?next=/files/User-Uploads

Regards,

Yamini Naidu

photo
1

Thanks Yamini.

I don't have access to the debug logs, could you let me know how to access those?

But doing the above didn't work, I'm still getting the "A connection could not be established to the source database." error.

But if I ask my colleague to run the same report and then i run it 2 mins after that, miraculously it starts working.

Screenshots attached for your reference.

Thanks

Khush

photo
1

Hello Khushboo,

Click the link below to understand how to enable debugging.

https://community.yellowfinbi.com/knowledge-base/article/how-do-i-turn-on-debug-logging-within-yellowfin-log-file

By doing this, share the debug logs in the same ftp link.

Additionally, the error appears to be a "connection time out"; may you kindly extend the time out? Adjust it to 10,000 or something comparable. Moreover, click the link below and let me know how it goes.

https://community.yellowfinbi.com/knowledge-base/article/troubleshooting-connection-instability-for-data-source-andor-config-db

Also if possible could you share the recording of the procedure you are following so that we can check and verify.

Regards,

Yamini Naidu

photo
1

Hello Khushboo,

Hope you are doing well.

I just want to touch base to see if you had chance to read through my response. If you can let me know that would be great.

Thank you!

Regards,

Yamini Naidu

photo
1

Hi Yamini

I don't have access to the logs, trying to see if there's a way I can get them. I tried to increase the timeout to 10000 but it still didn't help.

However, the issue still happens if I login directly using my normal account.

What is odd - I created a different user account for myself using another email address. When I login using that new user (on the same laptop) - this problem doesn't happen. Then I logout from the other user account and login with my own regular account - and there is no error on my account either.

This is very strange.

Is there some setting that causes unavailable data sources to be "Remembered" for a specific user account?

Thanks

Khushboo

photo
1

Hello Khushboo,

I'm sorry to hear you're still having trouble. Concerning your inquiry, "Is there some setting that causes unavailable data sources to be "Remembered" for a specific user account?" - No

To further investigate the problem, I require the debug logs files. Meanwhile, could you read the article below, try these settings, and restart the instance to see if the problem still exists. As I can notice a time-out problem on the screen shot you gave.

https://community.yellowfinbi.com/knowledge-base/article/volatile-data-sources-what-is-it-and-when-do-i-need-it

Please try modifying the refresh time in the data source settings as well.

01845106a3f78e98b613bd8eded3c859

Moreover, could you share the recording of the issue you are facing in the same ftp link shared above?

Regards,

Yamini Naidu

photo
1

Hello Khushboo,

Hope you are doing well.

I just want to touch base to see if you had chance to read through my response. If you can let me know that would be great.

Thank you!

Regards,

Yamini Naidu

photo
1

Dear Khushboo,

Greetings for the Day.

This is a follow up reminder that 2 days have passed without any activity in this ticket. When there's no activity, it usually means either that you have identified the solution for the reported issue or that the matter is no longer relevant and after 5 days (2 days from now) without any activity, we assume that the ticket can be closed. If this is not the case, please do reply and let us know how we can be of further assistance, we would be happy to assist.

Regards,
Yamini Naidu

photo
1

Dear Khushboo,

Greetings for the Day.

This email is to notify you that we believe that you have identified the solution for the reported issue or that this ticket can be resolved for now. Because of age and inactivity I am going to go ahead and mark this ticket as Completed. However, if you ever wanted to revisit this or have anything else I can help you with, please let us know, we will be more than happy to do so.

Regards,
Yamini Naidu

photo
Leave a Comment
 
Attach a file