Dependent report filters do not respect "select all" option

Stefan Hall shared this problem 22 days ago
Defect Logged

Hi,
actually everything is already in the title ;)
We have a parent filter and a child filter, whose values depend on the selection in the parent filter.

This works fine, depending on the selection in the parent filter the child selection list changes. BUT ...

In the ChildFilter the option "select all" is activated and my expectation is that therefore all entries are automatically valid and therefore selected and used. This is not the case and the report remains empty until I either manually select a filter entry or turn the "select all/none" option off and on again.

This is not at all intuitive for users and from my point of view seems like a bug.

;) Stefan (v9.8.0.1)

Replies (3)

photo
1

Hi Stefan,

I have captured the behavior in the attached video. Please let me know if this is what we are referring to?

Thanks,

Deepak

photo
1

Hi Deepak,
I am not sure. Please try the following procedure

1 deactivate "select all" for both filters
2 select for Region > "Europe"
3 activate for Country "select all"

Up to here everything is as expected

4 deselect "Europe" and select "Asia"

Now look at the lower filter, what do you see? Correct, a situation that does not match. "Select all" is displayed, but nothing is activated at all.

Either the design is bad and there should not have been an "on/off" toggle element, or the function is bad because no elements are selected despite being displayed. A bug in your UI.

;) Stefan

photo
1

Hi Deepak,

don't you think the behavior is wrong from the user's point of view?


Then let's turn this into a defect so your developers can start fixing it.

;) Stefan

photo
photo
1

Hi Stefan,

I have gone ahead and created a task with the wider team to review.

I will provide you with an update once I hear back from the team.

Warm Regards,

Deepak

Leave a Comment
 
Attach a file