Y-axis label is missing when report is shown in dashboard

Sam shared this question 2 months ago
Answered

My report has a y-axis label, "Total Rainfall (in)":/f50c016237940af405685f7160392dda

But when I put this report in my dashboard, that axis label is no longer visible:

/d1406b102726345919ec4ada2e7fa349

Is there anything I can adjust to make this axis label appear? I'm using a static layout with three columns, not a canvas. I see how I can switch it but it says that will remove all the reports, forcing me to recreate this from scratch. The static layout is working well here except for this one problem.

Comments (5)

photo
2

Hi Sam,

Thanks for reaching out to support with your issue.

I was able to see this in 9.6 i believe -


1. Made time series chart with Y-axis label -


179ccf33e57d7d2afca428c044c252be


2. Added Chart to 3 Column Dashboard - observed no y axis labels


591294143f277b3e4d61f8a386850a73


So I'm not sure if this is by design - 3 column static layout dashboards do get a little cramped, but I think what I'd want here is an option to hide or show the axis labels -


3f883d8fb8997c1857c257c047c48455


Does it look like I've got the behavior replicated accurately? If so, I can pass this to devs, along with any specifics in regards to the requested functionality. Just let me know if you could please.


Thanks,

Eric

photo
1

Yep that's exactly it. An option to show or hide the labels would be a great fix; even switching the default to always show labels would an improvement in the meantime.

Thanks Eric!

photo
1

Hi Sam,

Thanks for the reply here. So I did a search in our dev platform and it turns out there is a brand new fix for this! There is a new Axis Settings option that can "force" the axis label to display.


ba8ff6107326d090e6e59a916c8d2f0e


cd66eb0b2f67afdc42e754a30b37f6ed

Are you on 9.6, and if not is an upgrade a possibility here?

Thanks,

Eric

photo
1

That did it! I am on 9.6 and hadn't seen that feature. Dashboard looks great now.

Good to know where to look next time. Thanks again Eric!

photo
1

Glad to help, Sam!

I'll go ahead and mark this question as Answered at this time; feel welcome to reach out in the future.

Thanks,

Eric