US Zip Code GeoPack Not Loading

Elizabeth Tran shared this question 1 year ago
Answered

Hi - I'm trying to download the US Zip Code GeoPack, but assuming the file is too big that the loading times out. I referred to another error reported here and expanded the timeout seconds for the database from 180 to 20,000, but is still not working. Please help! Thank you!

Comments (5)

photo
2

Hi Elizabeth,


It's a pity we don't have your yellowfin.log file to confirm that it is indeed a timeout error, however, seeing as that is the most likely reason for an error to occur when trying to add the US Zip Code GeoPack to your Yellowfin, let's go with that for the moment.

I noticed that you said you increased the timeout from 180 to 20,000. This makes me think that you increased the timeout to a Data Source (because the default Data Source timeout is 180 seconds) instead of increasing the timeout to the Yellowfin database which is what needs to be done because what happens when you add a geopack to Yellowfin is that hundreds of thousands of rows are inserted into the GeoPack tables in the Yellowfin database, therefore the connection to the Yellowfin database needs to be kept open long enough for all of those new rows to be inserted.


So if my theory is correct, then all you've got to do to fix the upload error is to add the following block of code:


<init-param>
    <param-name>JDBCTimeout</param-name>
    <param-value>1800</param-value>
</init-param>

to the InitConnectionPool section of your web.xml file (which you will find in the path <Yellowfin directory>/appserver/webapps/ROOT/WEB-INF/) and restart Yellowfin.

The above example will set the timeout to your Yellowfin database to half an hour which should easily be enough.

Please let me know how this goes, and if we are unlucky and it doesn't resolve the issue could you then please send across your yellowfin.log file (from <Yellowfin folder>\appserver\logs) so that we can see the nature of the error.


regards,

David

photo
1

Yes, that finally worked! It took a while to load, but that helped so much. Thank you!!

photo
1

you're most welcome Elizabeth.

Thanks for letting me know!

regards,

David

photo
photo
1

Thank you for that info - the install took just under 30 minutes to complete!

photo
1

Hi Pedro,

that means the value of 1800 was just right!

Thanks for letting us know, I'm glad it worked out, albeit after a bit of a wait.


regards,

David