Upgrade require.js independently

YF Distributor South Africa shared this idea 5 months ago
Completed

Hi ,

Is there a way to update Yellowfin's require library to the latest version 2.3.6.?

Reason being the one yellowfin is using is 2.1.6 and seems like is not supporting highcharts even ouside yellowfin but the same chart works with 2.3.6, this is the reason I want to update yellowfin require library.

Comments (3)

photo
1

Hi,


Thanks for reaching out with your suggestion. I've logged this as an Idea for an Enhancement Request. Before becoming a request, ideas will be reviewed by our Product Team and chosen for Enhancements based on feasibility, level of positive impact to the user experience, and votes from the community.


This post will be updated with any future information relevant to this process.


Kind regards,

Simon

photo
1

Hi,


After speaking with Developers, it was determined that the require.js library could not be independently updated, however, they are looking into having this upgraded in upcoming releases of Yellowfin.


In terms of the HighCharts library, a workaround has been found by using ES module imports. I've attached an example Ski Teams Report, and in case you don't have the Ski Teams Database, the Javascript for the Chart.


Let me know if this helps, and I will reach out later down the track when the require functionality has been addressed.


Kind regards,

Simon

photo
1

Hi All,


I'm just messaging to inform you that with the version 9.7 release earlier last week, require.js has been upgraded to 2.3.6. You can download the latest version of Yellowfin in the Downloads section of the Support Centre.


This should mean that any JavaScript libraries and frameworks that depend on require.js should now be usable. Let me know if you have any further questions.


Kind regards,

Simon