Unable to Edit/ View Existing Joins between tables in Views

Chakra shared this question 1 year ago
Answered

Hello,

Hope things are going fine.

I'd like to share an error that I'm seeing when I try to view/ edit existing join logic in my View. Would like to know if anyone has seen this error and resolved it.


Attachment 1 is the error message that I’m seeing in all our envs (PROD, DEV, Pre-PROD). Same behavior on both Chrome/ IE 11.

I’ve tried to edit/View join from two places

  • From table property which is located at right end corner of View window. Refer Attachment 2

  • By double clicking on blue box that’s in between two table (Refer to attachment 3). Supposed to show the join condition when I hover mouse pointer over on top of blue box but that’s not showing up either.

I tried to look for this issue in YellowFin community and others but could not find relevant info other than below two points which I’ve already performed with no success.

  • Clear browser cache

  • Disable pop-up blocker

Appreciate your assistance on this please.

Thank you,

Chakra

Comments (9)

photo
1

Anything on this please?

photo
1

Hi Chakra,

Thanks for your email.

I am just wondering which company are you working for as I couldn't find you in our CRM.

I have similar issue reported by another client.

If can let me know, I may do a separate reply or may merge the tickets.

Regards,

Mahesh

photo
1

Hi Charkra,


Just checking in on this, we believe we are dealing with this issue via your Yellowfin contact, so if you could please clarify your company (as it's showing up as gmail), then we can merge the requests and ensure we're all on the same page.


If you're unsure how to tell this, that's ok, just change your community email to your work address and we can do the rest.


Thanks,

David

photo
1

Hi Charkra,


Not sure if it is the same issue or not, but I've seen early builds of Yellowfin 7.3 use pipe characters '|' in the view join dialog URL. The pipe character is not a standard character for a URL. Depending if you have upgraded Tomcat independently of Yellowfin, it may auto-reject such URLs. If so you may see something like the following in your catalina.out log:


INFO [https-openssl-apr-8443-exec-9] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header

java.lang.IllegalArgumentException: Invalid character found in the request target. The valid characters are defined in RFC 7230 and RFC 3986


This also might be an issue even if you haven't upgraded Tomcat if you have an additional proxy / load balancer software sitting in front of Yellowfin.


Again, could be something else. Do you know the Yellowfin build you are using?

photo
1

Hi David Registro and Mahe Thattipamula,


I've updated my community email to my work address.

Thank you,

Chakra

photo
1

Thanks Chakra,


I believe what you're facing is in relation to security configuration which is blocking specific pop-ups.

This is being investigated via another ticket where we will continue the discussion.

photo
1

Hi David,

I am having similar issue while editing the joins(with external tomcat). Do you have any resolution for the same?

Regards,

Bharath

photo
1

OK, I have fixed it by un-commenting the tomcat.util.http.parser.HttpParser.requestTargetAllow=| under catalina properties file. This is an issue from the tomcat side.

-Bharath

photo
1

Nice stuff Bharath! Thanks for letting us know :)

photo