Top 100 rows shown

Stefan shared this question 6 months ago
Answered

I'm looking for a way to show top 100 rows in descending order in Yellowfin.

I'm not looking for top N rank, I want to limit the rows being shown to 100.

The "active row limit" does the job of showing limited amount of data but cuts data at the wrong time (data is being culled before filters are administered, so I'm getting wrong data).

How can I achieve top 100 with correct data ?

Without active row limit:


6a548dca428a8c4fa353c4624153bbc3


With active row limit set to 100

456baf1f7f74d3b46871f4e7a2c43ede

Comments (3)

photo
1

Hi Stefan,

Just had a quick chat to one of our consultants and we believe the only 2 things you could do in this case is to

A. Possibly use the same field twice in the report, select a top n(100) ranking on the second field, sort it by descending and then hide that field so it does not show in the report. You could then leave the Row limit to what ever is your default. Does that make sense? This may or may not work though as it would depend on other columns in the report so option B might be the better choice.

cf7ebcde91c620cc519ce2c109d5c9ddor

B. use Feehand SQL in the report or as a view using the SQL top n syntax such as found here.

Information on Freehand SQL reports can be foud here and Freehand Views can be found here

Hopefully this will provide you what you are looking for.

Cheers,

Paul

photo
1

Hi Stefan,

Hope you're having a good week.

Just wanted to check-in and see how it's all going. Was there anything you were needing from me to help get this resolved?

Regards,

Paul

photo
1

Hi Stefan,

Just checking in again on this to see if you need any more help with this?

Regards,

Paul

photo
1

That would be all.


Thank you very much Paul

photo
1

Hi Stefan,

No problems. I will mark this as Answered, but feel free to get back in touch as required.

Regards,

Paul

photo