set default content language?

Stefan Hall shared this question 14 months ago
Answered

Hi,

we have only german speaking users, so we configure everything "view names", columns, etc. only in german.


But we retrieve data from a system that distinguishes between en/de and without adding "german" as language in the region setting, we get the content in english.

As soon as I add "german" in the language settings, all content is returned in german from the source system.


I conclude that no language is given in the default or it is set to "en" regardless of the browser display. Wouldn't be so bad if the "additional" language "german" wouldn't unlock the translation function at the same time. This is not necessary in our case.


Can we influence this and set the default base language already to German?

;) Stefan

Replies (4)

photo
1

Hi Stefan Hall

Thanks for reaching out yellowfin support

I would like to recommend you to go through the below wiki links because it has all the information about language. (https://community.yellowfinbi.com/knowledge-base/article/supported-languages). (https://wiki.yellowfinbi.com/display/USER74/Content+Translation)

(https://wiki.yellowfinbi.com/display/USER74/Installer+Behaviour#InstallerBehaviour-Language)


Please let me know if there is anything else I can help you with.


Regards

Siddhartha

photo
1

Hi Siddhartha,

We have misunderstood each other, the basic principle is clear to me.


I would like to not have to set "German" as an additional language in the language settings, so that the option "Content translation is not activated. If I don't enter "german", YF UI will be displayed in German depending on the browser, BUT the data from the data source will be retrieved in English.


That means there must be a default setting somewhere in the system or the YF DB.


;-) Stefan

photo
photo
1

Hi Stefan Hall

Thank you for your response. We'd like to talk to you remotely for further understanding purpose. So that we can schedule a meeting based on your availability , kindly let us know when you'll be free. I am available Tuesday to Friday 21:00 IST to 06:00 IST


Regards

Siddhartha

photo
1

I'd love to, but my english is a bit rusty. if you want me to show you something, I'll have to invite you to a skype session. All other tools are forbidden here.


Can you move this post to a private area, I don't want to share my link with everyone ;)

photo
photo
1

Hi Stefan Hall

Thank you for your response. I will check with my wider team and get back to you soon.


Regards

Siddhartha.

photo
1

Hi Stefan Hall

Apologies for delay. There is no option to designate German as the default language. The only language available from the Yellowfin UI is English; however, if we want to choose German, we must go to the region settings and modify the language there.

The global language of a Yellowfin instance can be overridden in one way. through a modification to the configuration database. You should be aware that doing this will change all of the instance's client languages to the selected language. I would like to recommend you to go through the below article.

https://wiki.yellowfinbi.com/display/yfcurrent/Advanced+Configurations#AdvancedConfigurations-Enforceagloballanguage

So for Germany it would be

INSERT INTO Configuration VALUES (1, 'SYSTEM', 'OVERRIDE_LANGUAGE', 'de_DE');

Here, in the regional settings of the Yellowfin server, we must disable Multi-language deployment before inserting the query. I tested the above query in a local instance to see how it would change the entire language. After entering the query, kindly restart the yellowfin.

I have attached screenshots for your reference.

e2feb7656a648c0da33050b0165c8c72

After entering the query the dashboard is changed to German language as you can see in my below screenshot.

bd6e62b308e55d8cdea9be84ad294259


Please let me know if there is anything else I can help you with.


Regards

Siddhartha

photo
1

Hi Siddhartha,

i think that helps us. You can close the ticket.

Happy New Year!
;) Stefan

photo
1

Hi Stefan Hall

If that's all good, I'll go ahead and mark this as complete. Feel welcome to reach out in the future.

Happy New Year.

Regards,

Siddhartha

photo
Leave a Comment
 
Attach a file