The max row limit has been reached.Cannot edit the row limit

Devi Shyam shared this question 11 months ago
Answered

If I am generating a report, the rows are getting truncated. I wanted to increase the limit but not able to do it.

I think I missed to change some settings. Can you please help me on this

Warning after publishing the report

/++I6XjnrU8kjwjUYCEpCABCQggckSUBGbbNGYMAlIQAISkIAEJCABCUhgWwm4NHFbS9Z8SUACEpCABCQgAQlIQAKTJaAiNtmiMWESkIAEJCABCUhAAhKQwLYSUBHb1pI1XxKQgAQkIAEJSEACEpDAZAmoiE22aEyYBCQgAQlIQAISkIAEJLCtBFTEtrVkzZcEJCABCUhAAhKQgAQkMFkCKmKTLRoTJgEJSEACEpCABCQgAQlsKwEVsW0tWfMlAQlIQAISkIAEJCABCUyWgIrYZIvGhElAAhKQgAQkIAEJSEAC20pARWxbS9Z8SUACEpCABCQgAQlIQAKTJaAiNtmiMWESkIAEJCABCUhAAhKQwLYSUBHb1pI1XxKQgAQkIAEJSEACEpDAZAmoiE22aEyYBCQgAQlIQAISkIAEJLCtBFTEtrVkzZcEJCABCUhAAhKQgAQkMFkCKmKTLRoTJgEJSEACEpCABCQgAQlsKwEVsW0tWfMlAQlIQAISkIAEJCABCUyWgIrYZIvGhElAAhKQgAQkIAEJSEAC20pARWxbS9Z8SUACEpCABCQgAQlIQAKTJaAiNtmiMWESkIAEJCABCUhAAhKQwLYSUBHb1pI1XxKQgAQkIAEJSEACEpDAZAmoiE22aEyYBCQgAQlIQAISkIAEJLCtBFTEtrVkzZcEJCABCUhAAhKQgAQkMFkCKmKTLRoTJgEJSEACEpCABCQgAQlsKwEVsW0tWfMlAQlIQAISkIAEJCABCUyWgIrYZIvGhElAAhKQgAQkIAEJSEAC20pARWxbS9Z8SUACEpCABCQgAQlIQAKTJaAiNtmiMWESkIAEJCABCUhAAhKQwLYSUBHb1pI1XxKQgAQkIAEJSEACEpDAZAmoiE22aEyYBCQgAQlIQAISkIAEJLCtBFTEtrVkzZcEJCABCUhAAhKQgAQkMFkCKmKTLRoTJgEJSEACEpCABCQgAQlsKwEVsW0tWfMlAQlIQAISkIAEJCABCUyWgIrYZIvGhElAAhKQgAQkIAEJSEAC20pARWxbS9Z8SUACEpCABCQgAQlIQAKTJaAiNtmiMWESkIAEJCABCUhAAhKQwLYSUBHb1pI1XxKQgAQkIAEJSEACEpDAZAn8P7uFAbv0Oi31AAAAAElFTkSuQmCC

Tried to change it when editing the report

/wChWJdramE8yQAAAABJRU5ErkJggg==

But still coming as 10000. I think I need to change the settings in Configuration. Can you please help me? I . have checked the help guide also but couldnt find the option.


Kind Regards,

Devi Shyam

Comments (3)

photo
1

Hi Devi,

there is also an Active Row Limit in the Data Source (it's called Max Rows Returned), and also one in the View (called View Row Limit), and the order of priorities is that the Data Source Active Row Limit overrides the View Active Row Limit which in turn overrides the Report Active Row Limit.

The Data Source row limit is by default 10,000, whereas the View limit doesn't have a default, so therefore it is most probable that your 10,000 row limit is coming from your Data Source. So if you increase it there, or remove it altogether, then that will stop the truncation message appearing in your report.

Please let me know how you get on with this.

regards,

David

photo
1

Hi David,

Can I increase the row limit? If yes, where is the setting?

Regards,

Syed

photo
1

Hi Syed,

yes you can increase the row limit, or you can even turn it off so there is no limit at all.

Please read the above response that explains where the settings are, and gives you the relevant wiki links, and also explains about the order of priorities of the 3 separate row limit settings. And of course, if any questions or issues should arise after reading that then please let me know.

regards

David

photo
1

Hi Syed,

just checking up, how did you get on with increasing the row limit?

regards,

David

photo
1

Hi Syed,

there's been response for over a month now so will mark the ticket as closed, but if you feel that this decision has been made in error then please feel free to reopen it by adding a new post to it.


regards,

David

photo
photo
1

Hi David,

Can we increase the row limit beyond 10,000. If yes, where can I do this?

Regards,

Syed

photo
1

Thanks Big Dave! Your in-depth response helped me immediately. I did not think to check the Data Source....

Thanks,

Scott