SQL*Net message to client wait

Bernard Anderson shared this question 20 months ago
Answered

Oracle 11.2.0.1

Yellowfin 7.1 on Windows Server 2012 R2 64Bit


When I edit a report and then save returning the saved report takes a long time. If I look at the Sql call at the database I see a lot of "SQL*Net message to client" against table cachedfiltervalue.

Nearly all my reports use an access filter with 160 odd entries so cumulatively the query need to return

Most reports have up to 6 'dependent' filters

I have a LOT of cached filters some of which have a lot of rows. The table contains > 12M rows.

Sample query attached:


Anyone any ideas on how I can improve the situation?

DB Stats are up to date, all the indexes are in place


I am the admin/DBA so any parameter changes welcome :)

Comments (3)

photo
1

Hi Bernard,


there may be a couple of config changes you can make to your yellowfin install - Volatile Sources and JDBC Verify


Volatile Sources:

https://community.yellowfinbi.com/knowledge-base/article/volatile-data-sources-what-is-it-and-when-do-i-need-it


JDBC Verify:

https://community.yellowfinbi.com/knowledge-base/article/jdbc-verify


Enabling both these options may help in keeping the connections alive and responsive for large or long running queries.


Please let us know how you get on!

Best regards,

Pete

photo
1

Thanks,

I do not see any of the connection errors mentioned here so will hold off on these settings. I did however find an article on setting the initial cache values and found that adding an entry for CachedFilterCahceSize seems to have improved things.


You may close this request :)

photo
1

Hi Bernard,


Thanks for letting us know!


Closing this ticket.


Best regards,

Pete