Setting Default value in dashboard filters

Roopinder shared this question 5 months ago
Answered

I have set the default value (i.e Last 8 weeks) to date filter in report tab. But when im using the same filters in dashboard, I need to press apply button to load the dashboard with defaullt value which i set at report level.


is there any way to load the dashboard with default value when first loaded.

Best Answer
photo

Hey Roopinder,

Ok I have tested this out in version 9 also and I am still able to add the filter with the default values Asia and Australia - please see below for my example -

Creating the report before selecting default values for my filter -

de94419b17d85db3ddf52390e5bf92f1


Selecting the Default values to run on load -

27e3970ab1befb7c7ef7a582d83525e3


How the report looks with default values selected -

8189ec7998fdb0b55d90205bec19b3cf

In the Dashboard setup - select the filter icon on the left side - drag the filter box into your dashboard and select the filter you would like to be linked the reports. IN my case, i only have one filter set up for the one report in my dashboard, so this automatically appears and i just checked the box for 'athlete region'

caf2ff58392f1dd3516364b3738e78d7


And then here is my dashboard once saved with the default values still selected -

2c35751ceed81e0e31aa9ba218c8020e


I hope this helps - Let me know if not!

Best Wishes,

Lesley

Comments (9)

photo
1

Hi Roopinder,

I hope you are well!

Yes, this is possible, If you go into edit mode on your dashboard tab, and go to your filter tab, you should be able to select the default values you would like to be displayed when first loading the report in the dashboard, the same as when first loading a report on its own.


9be5fd34666d3f89e3ea030aa3d28933


I hope this helps!

Please let me know if you have any further questions, I will be happy to help :)

Best Wishes,

Lesley

photo
1

Hi Lesley,


Thanks for you prompt response.

Actually i'm using the yellowfin 9.0 version. No such option is there for filter setting at the dashboard level.

What you have told, i have made all the settings at report level. But no such option at dashboard level.

photo
1

Hey Roopinder,

Ok I have tested this out in version 9 also and I am still able to add the filter with the default values Asia and Australia - please see below for my example -

Creating the report before selecting default values for my filter -

de94419b17d85db3ddf52390e5bf92f1


Selecting the Default values to run on load -

27e3970ab1befb7c7ef7a582d83525e3


How the report looks with default values selected -

8189ec7998fdb0b55d90205bec19b3cf

In the Dashboard setup - select the filter icon on the left side - drag the filter box into your dashboard and select the filter you would like to be linked the reports. IN my case, i only have one filter set up for the one report in my dashboard, so this automatically appears and i just checked the box for 'athlete region'

caf2ff58392f1dd3516364b3738e78d7


And then here is my dashboard once saved with the default values still selected -

2c35751ceed81e0e31aa9ba218c8020e


I hope this helps - Let me know if not!

Best Wishes,

Lesley

photo
1

Hi Lesley,

I have made all the setting such as ( Default value to run on laod) at report level. And can able to see the default value at dashboard also. But after loading the dashboard, i have to press apply button to load filter with default value.


Just set the default value and close the dashboard. When you again try to open it, default value will be there but you have to press the apply button. Then only dashboard will load with the value.

Can you please check. Is this a bug.

photo
1

Or it there any way to remove the apply button, so the filter will work properly.

photo
1

Basically, I just need my dashboard to load with default filter applied without pressing apply button.

photo
1

Hey Roopinder,

Are you able to show me how your filters are configured in the report? How have you set up the default filter values?

I have recorded is a video of my attempt of this, where I am getting the results you desire...? In my screen recording, I start off with not having any default values set up in my filter settings and then I add the default filter values which are automatically applied to the dashboard and keep even after changing tabs/ logging out and in again.

Please click here to see my video

And let me know if your default value setup in the filter settings are any different so I can try it that way instead. :)

Thanks & Best Wishes,

Lesley

photo
1

Thank you so much @Lesley for the detailed explanation. Appreciate your efforts.


Yes, I got it. Its working now.

photo
1

Hey Roopinder!

That is so great :) I am very pleased you resolved this issue!

I will go ahead and mark this question as Answered, however, if you have any further questions, please do not hesitate to ask as I am more than happy to help!

Best Wishes,

Lesley