Setting a Target for Meter Chart does not work

Bharath Kumar shared this question 21 days ago
Awaiting Reply

Hello Team,

I am trying to create meter chart in YF 8.0.4. I have Number of Incidents SLA met is 78% and Breached are 22%. I am trying to point the needle to 78 which SLA Met Inc. But meter chart always picks 100%.

- In my report, I have SLM Status(Breached/Met) and Number of incidents.

- Change Number of Incidents advanced function to analysis-percentage of total

- Added conditional formatting on Number of Inc.


Refresh Data.

You should get something like this:


% of Total of Number of Incidents 78 and Breached 22%.


Add a meter chart and put to measure the analysis field % of total of number of incidents.The needle always shows 100% on the meter chart. So I created a variance function in chart and dragged it in target. Defined the filter logic as SLM Status = Met. I assume it should display Num of Inc which are SLA met.


Attached screenshot. My question is how can I make the needle to display based one of the value like SLA Met incidents in my case.

Comments (10)

photo
1

Good Morning, Bharath,

I hope you are well!

At first glance of the screenshot you have provided, it looks like you may need to switch the fields arounds. % of Total number of incidents in the Target box and then the 'BMC' in the measure box.

Let me know what results this produces?

In the meantime - I will test out locally and let you know how it goes :)

Best Wishes,

Lesley

photo
1

Hey Bharath,

I just did a quick test to show my results when putting the total amount in the target field and the actual numbers in the measure field -

c6c2a20f8dec3ffd9c820fe6a9cfe8a5


In your screenshot, your target says '78' where this should be the measure.

Let me know how it goes! I hope this has helped :)

Best Wishes,

Lesley

photo
1

Hi Lesley,

We tried this, indeed the needle shows correct value, but the conditional formatting is lost in the report.

We defined different colors for % Number of Inc, but with approach the whole chart is turned to blue color.

Regards,

Bharath

photo
1

Hey Bharath,

Could you try applying the conditional formatting to the field put into the measure section? So if you use conditional formatting on the 'BMC' field, the same way you did it on the '% of' field, this should work :)

I hope that helps - Let me know

Best Wishes,

Lesley

photo
1

Hello,

The field BMC is a Set Analysis function from the chart. I cannot apply conditional formatting on it, I dont see way to apply conditional formatting on Set Analysis functions.

Regards,

Bharath

photo
1

chart turns blue with default coloring as I add Set Analysis function to Measure. Since it is a run time function, I guess it does not have ability to define conditional formatting.

photo
1

Hey Bharath,

I hope you are well!

I am so sorry, I missed the fact that this was a set analysis!

I tested this out and I believe this is expected behaviour, because the set analysis is independent from the report, so it will not have any formatting rules from the report to hold.

When testing this out, I used a date field as a filter in the set analysis for a specific year (2011) and received the same results as yourself, the whole colour band turns to the default colour. -

a97045f41b73eb87157b3d991aa58b42


However, when setting this up via the report builder an NOT the set analysis, I was able to receive the same results on the chart, but this time, the colour band will hold the conditional formatting -

60ebb7bc1a9752b9a15bdb7a84b41d24


So -

  • Instead of putting the field from the report in a set analysis, I put it in the 'measure' section
  • Instead of applying the filter in the set analysis, I put it in the 'Filter' Section of the report builder

Is this a viable option for you to try?


Let me know your thoughts :)

Best Wishes,

Lesley

photo
1

Hi Lesley,

If I put filter in report and pull Number incidents with SLA met, but I get 100% in chart.

Regards,

Bharath

photo
1

Hey Bharath,

Could you show me where you have placed the fields in the chart builder? and could you test switching them around?

Best Wishes,

Lesley

photo
1

Hey Bharath,

Hope you are well :)

Just wanted to check in on this ticket to see if you swapped the fields around in the chart builder and then adding the conditional formatting to the field in the measure box made any difference in helping you get the desired results?

Let me know - I will be happy to continue looking into this with you if you need!

Best Wishes,

Lesley