restyling/configuring the Incomplete Filters page

Bill Perrello shared this question 2 years ago
Answered

We have many reports that used the cached filters option. We have encountered many instances where the cached filters no longer refresh successfully. Our believe is this is due to data volume of the report without a filter being used to ascertain filter values. The solution we have for the short term is to change the filter from a cached filter value to a custom query. This does work, however no option exists for the default value to be selected to be anything other than Omit. This has previously been listed/requested as an enhancement I believe. (We are currently using 7.2 Build 20160728). As a result of this decision to used the custom query filter, and the inability of the product to support a default value other than omit for a mandatory filter, we end up with reporting not automatically running and displaying data; but instead displaying the "Frowny face" page with the Message "Incomplete Filters". We find this to be not the best customer experience for our users. Is there a way to mitigate this experience at least by being able to re-style and change the contents displayed on the "Incomplete Filters Page"? Also - can you provide me a status update8ac6cfc4c21c95419ec2ff912736b775 on the above mentioned request for enhancement?

Comments (5)

photo
1

Hi Bill,


Regarding your second question, it is possible to change some of this, though many of the settings are global and used elsewhere in the program.


The frowny face: this is an image pulled from the image folder. You can change this by replacing the image.


The frowny face appearing in the first place: I am not sure where this is but my guess is that it is added through JS. If you are interested in changing this, let me know and I can dig deeper.


The CSS controlling the look: this is pretty generic and will effect all in-report error popups. If you want to change this let me know and I will try to look for the specific tags.


The text: This is controlled through the ApplicationResources file. To adjust this text:


  1. Create a new folder structure in your WEB-INF folder: classes/com/hof/
  2. Extract the current ApplicationResources.properties file from the i4-core.jar library, and save it to this folder.
  3. Search for the text you want to change, and change it
  4. Find the text.js file in the ROOT/JS/text folder, and edit it to reflect these same changes.
  5. Restart Yellowfin


b9fb63c82e9ea02055bcb3bb8ba7ff7aAdditionally, I have been attempting to adjust the legend look as we discussed in the last call. I have not had any luck with this but am going to make a task ticket to see if any of the devs have a better idea on how this can be done.


Regards,

Nathan

photo
1

edit**

photo
1

Hi Bill,


Quick clarification on the enhancement, are you referring to the filter menu not saving in views from stored procedures? This one has been fixed and is included in the 20171201 build released a couple of days ago.


If you are not referring to this one I am a bit confused, do you have an enhancement/case number? In the most recent build it is possible to use default values in mandatory custom query filters.


Regards,

Nathan

Nathan

photo
1

Hello Nathan. Thanks for your note. My company recently underwent fairly rigorous testing of YF 7.3 as you know . For a few reasons, we were not able to make the jump to YF 7.3; but now are on 7.2 Build 20160728. As of that particular release, it was not possible for custom query filters to have a MIN or MAX value set as the default. If you are saying that the most recent (November) build of 7.3 now supports this; I will say that some small portion of our prayers have been answered. However; it will not help us until we are able to upgrade to a later version. Can you send me a screen shot of same along with the version and build number the screen shot comes from. Your ideas on how to influence the "Incomplete Filters page" are graciously received and will be explored. I can see that we will not be able to explore them until the new year - so in the meantime you can feel comfortable in being able to close this ticket (after you send me a screen shot mentioned above) with my thanks.

photo
1

Hi Bill,

Is this issue related to stored procedure views? I have attached ski-team replication from a pretty new 7.4 build.


Let me know if I missed anything.


Nathan