Report's filter for embedded report

Eliran Jerby shared this question 3 years ago
Answered

Hi


We have a report with some parameters, some of them with default values and some are not.

When report is loaded inside the Yellowfin environment it looks fine and the Filter list is shown.

But, when the report is embedded inside html page, the filter list is not visible and the user must press the Filter button to make it visible.

How can we make it visible when loading?


Attached screen shot of the report after the html is loaded.


Regards,

Eliran

Comments (2)

photo
1

Hi Eliran,


Thanks for getting in touch. We're likely going to need some further information about the setup of your filters in order to create a mirrored report on our end. I tried making a report with some default values and some that needed a user entry, and then embedded it into an HTML page. Everything worked for me, and the filters loaded automatically when I opened the page.


So, could you tell us a little about the filter set up that is being used for this report? Are the filters all using cached values? Are all of the filters set to Mandatory, or are any of them set to Allow Omit? On the Output tab in Filter Formatting -> Actions, is the Autorun Report on Load setting set to 'On'? Have you tried embedding any other reports? If so, have you experienced this same behavior on those reports as well? Additionally, what version and build of Yellowfin are you using? This can be found under Admin Console -> System Information


There are also a couple of options in the Javascript API that may be helpful. For information on this, I'm going to point you to the Loading Report Filters section of the following page on our wiki:

http://wiki.yellowfin.com.au/display/USER72/Advanced+Use#AdvancedUse-LoadingReportFilters


If you could fill us in on the information requested above when you have a moment, that would be great. Thanks in advance for all of this!


Best,

-Conner

photo
1

Hi Eliran,


We assume this is all ok.

Closing it up.


Please let us know if this is not the case.


Regards,

David