Reports - axis formatting issues

Peter Flinn shared this question 2 years ago
Answered

Vertical axis: if the view data is '%' then why is this not expressed on the vertical axis the same way? The data comes out as a number in the report.


Horizontal axis: need to force this to show all items from the view data. Currently it shows alternative items only.

Comments (9)

photo
1

Hi Peter,


Unfortunately I am going to need a bit of clarification/elaboration here to really get what you are talking about. Can you include a couple screen-shots?


Regards,

Nathan

photo
1

Screenshots attached. You can see the data is in '%' form and the graph x axis is not. I need the axis to properly reflect the data type.

photo
1

Hi Peter,

Unfortunately, only the Auto-chart does this sort of formatting well, though enhancements have been raised to have this transferred to other chat types. I would suggest labeling the axis with a title that highlights these units.

Sorry for the inconvenience.

Regards,

Nathan

photo
1

Thanks Nathan - can this be submitted as a necessary improvement? All charts should reflect the format of the data, surely.

photo
1

Hi Peter,

I am not sure how I forgot about this, but you can already set the prefix on these numbers:

a23e642a800f0d6a76a72970beb35b7c


Let me know if this works for you.

Regards,

Nathan

photo
1

That won't work Nathan: if a % number appears as .5 on the axis (in the data its 50%) putting a suffix (in this case, not a prefix) behind it would make it .5%, which would be incorrect. It's just not formatted correctly by the chart, and I think this must be a bug or something which may need looking at.

photo
1

Hi Peter,

I assume you are using the percentage formatter here? Formatters such as this are actually returning a text value. Since the chart needs to build its axis numerically, it is forced to use the non formatted value. This is why we provide formatting options such as the prefix, which are already available at the report level, again in the charting menu.

Instead of using the formatter, would it be possible to create a calculated field that simply multiplies your value by 100? You could then use the Prefix as shown below.

Regards,

Nathan

photo
1

That's my usual work-around in these cases. I suppose I raised this as an issue because it just seemed an unnecessary thing to have to do. I'll continue to use that approach for the time being. Thanks for your help.

photo
1

Hi Peter,

I agree that the way you are expecting is more logical, but glad that the work around will at least get the job done. Sorry for the inconvenience!

Regards,

Nathan