Report when exported to Excel the cell format shows as TEXT

Sunhith shared this question 2 years ago
Answered

Hello Team,

Since we upgraded,.. Report when exported to excel the formatting number cells show as Text (see attached screenshot). How can we go back to the previous correct formatting?

Version 7.3 to--> Version 8.0.02

This all happened after the upgrade, nothing was changed.


Screen shot attached

Comments (7)

photo
1

Hi Sunhith,

Thanks for reaching out. This was a change made starting in 7.4.7 and we created a fix to go back to the old way along with a required configuration change for this as of 8.0.4. You can find the fix onwards from 7.4.11, 8.0.4 and 9.0.

So to resolve this, you have to upgrade to one of the aforementioned builds or later, and also execute the following INSERT statement to re-enable this:

INSERT INTO configuration values([PrimaryOrgIp], 'SYSTEM', 'EXPORTXLSNUMERICVALUES', 'true');

After executing the INSERT INTO statement, you'll have to restart Yellowfin, from which point these changes should be picked up.

Please let me know if you have any questions on this.

Regards,

Mike

photo
1

Hi Sunhith,

I just wanted to check in and make sure my response found you okay.

Regards,

Mike

photo
1

Hi Sunhith,

I'm going to go ahead and mark this one as Completed since I haven't heard back from you, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike

photo
1

Hi there,

I'm getting the same behavior using YF 9.6. I looked in the Configuration table...looks like the configcode is REPORTDEFAULTEXCELEXPORT and the configdata = true. I'm reluctant to make changes since we're a couple versions ahead of this post. Can you please advise? The calculated metric cells are all coming up as Stored as Text error.


Thanks!Craig

photo
1

Hi Craig,

I hope all is well,

I have since looked at this and so far no fix of this yet with regards to having this implemented in a version/build however I can see progress for the ticket that we have with our development team, one is hoping this will make our next version/build release.

I will mark this as Answered but please. do not hesitate to re-open for updates etc.

Regards,

Mark

photo
1

Thanks Mark, I guess I thought it was already fixed in a previous version, but thanks. I'll stay tuned.

photo
1

Hi Craig,

No problem, as said please do not hesitate to reach out for updates, I would be more than happy to deep dive in to this for you.

Enjoy your week ahead.

Regards,

Mark