Parent filter not changing values of Child filter

Austin Hart shared this question 56 days ago
Answered

I have 3 reports on a dashboard.

The parent filter - organization is a filter on all 3 reports.

The third report has 2 additional filters.

I have those 2 additional filters specifying the organization as the parent.


Organization filter is single select only manadatory- cached values.

Names Filter - Parent is organization, Dependent(Only values related to the selected parent values will be displayed.), allow omit, cached values and no default value chosen.


Question

What's happening is when I change the parent filter value - my 2 dependent filters are not changing to reflect only the values for that organization.

How do I get the children filter to only reflect the values from the parent value?

Comments (3)

photo
1

Hi Michelle,


Thanks for reaching out to us on this. To link the parent filter to the children on Dashboard, you will need to go into the Edit mode for the Dashboard and click on the Analytic Setup and click on each on the Linked Report names to set up with filter links (in the example below, I clicked Athlete Age Group Breakdown ND).


75c0bbc185b7baec24ba24a52b02e985


From the screen below, select the parent filter you wish to link (in your case, Organization). Repeat this step on each report with the dependent filters.

3817d728c4dcccb6d984642d98abc743


If you have these set and the Dashboard published and it is still not working, please let me know and we'll work out what is happening.


Cheers,

Neal

photo
1

Hello Neal,

Yes - I have them all linked. I have them linking to existing filters. My main one that displays the filter is what i link them all to .

Link3 is the result - the filters are blank and I'm not sure why.


So I'm having really 2 issues.

1.One is they are now blank. I can't get data to show up at all in these filters. I'm not sure what happened.

2. used to have data but didn't change based on main filter.

photo
1

I got it to work. Had to change how i was displaying the filters on the dashboard.


On the dashboard filters when I’m linking them – I have to display the filters that have the parent child relationship So I had to display the organization and full name from the same report and then link to the other reports. I didn’t think it matter what report I displayed organization on because they are linked and it should have done the parent/ child refresh. This is what has worked but I’m not sure if that is the only solution for this.

photo
photo
1

Hi Michelle,


Glad you got it working. If I am understanding you correctly, you needed to show the Filters on the "Parent" report to get it to work? This is generally the accepted way to do this, however if you have had to make another modification please let me know.


If all is good as it is, please let me know and I will consider this resolved for now.


Cheers,

Neal

photo
1

Yes - It wasn't something intuitive to figure it out but after trial and error I finally got it. You can close this ticket. Thank you

photo
photo
1

Hi Michelle,


Happy to help, let us know if you run into anymore issues with this.


Cheers,

Neal