not supported by MIViewFieldsAjaxStatelessAction

Dan Cotton shared this question 2 months ago
Awaiting Reply

We are getting the following error when trying to edit permissions on about of half dozen views. we have several other views that can have the permissions edited without issue. Most os these views have existed for a while and been through several YF updates. We are currently running 9.8.0.1

I have attached the java output error text in a file

Error caught: java.lang.IllegalStateException: is not supported by MIViewFieldsAjaxStatelessAction

Replies (5)

photo
1

Hey Dan,

We're experiencing the same thing but have yet to find a solution

I'm currently going through the XML files that are generated when exporting a view and am comparing a broken vs a known working one.

It's slow going as it's 000s of lines and I'm doing it in between other work but if I find the issue and it's not otherwise solved, I'll post back here

photo
1

Hi Dean. I also tried copying the View and then making the changes on the "copied" View, but get the same results.

In the "copy" I also tried modifying some of the aspects of the View and saving in the hopes that it would "fix" what ever was the underlying issue but it was a no-go. (I was able to save the View without issue in all cases)

photo
1

Have done the same! We luckily had a version of a view on our Dev environment that still allows permissions to be edited. While it is not 100% the same as the production version, it's similar enough to make for an easier comparison.

In a previous attempt, if I replaced certain sections of the broken one, with ones from the working, it worked but it was a flawed test as things like field IDs were different and not consistent in the same file so I couldn't tell what exactly was broken in the original

The current comparison I'm doing is better but there's a massive section left to compare so it's taking me longer to complete

photo
1

Hey Dan

This appears to be fixed in v9.8.1

I haven't tested all affected views but I had no issues editing security settings on the ones I did test


Thanks

Dean

photo
1

Hello Dan Cotton,

Hope you are doing well

Just want to touch base to see if you had chance to read through the response of Dean Flinter.

This seems to be fixed in 9.8.1 version.

Let us know if that works for you

Thank you!

Regards,

Yamini Naidu

Leave a Comment
 
Attach a file