MIRequireLogin.i4 page producing error when trying to log in as the existing user

Dillon Hoefener shared this question 11 months ago
Answered

We have a custom login page in effect, and I mention that for 2 reasons:

1. We have no issues with with our custom UI.

2. We did not have any issues with this behavior prior to implementing the UI (I believe in YF 9.3 and we are not running 9.5.1.

For some reason, I find that I am still navigated to the MIRequireLogin page sometimes, on a timeout for example, but NOT on every timeout. The expectation is that we would reroute the MIRequireLogin page to our custom page. If we can't do that, we need to at least make sure we can login in if we hit it and remove the Yellowfin log as this is embedded into one our homegrown systems. Ideal there is to make it look more like our custom login form instead.

Please advise.

Thanks

Comments (9)

photo
1

Also, forgot to mention the log states ERROR (LogonProcess) - [833139] [3E726EAA] [/MIRequireLogin.i4] Primary org not found so I'm not sure where that needs to be defined since we only have the one iporg of id 1.

photo
1

Hi Dillon,

Apologies for the delay. I have been able to replicate the inability to re-login on 9.5.1, though so far I still get my custom login. I will do some more research on this and come back to you tomorrow with some more information as I will need to dig into the routing process to see if we can help you with that side of it to start with. I suspect there may be a bug with the re-login and I will test an upgrade to 9.6 to see if that has been resolved there or if it needs raising.

Finally, are you embedding this in an iFrame? If so I will test that as well for completeness.

Cheers,

Neal

photo
1

Hi Dillon,

Apologies for the severe delay on this. I have been continuing to experience mixed outcomes on this and I can see a couple of tasks that relate to this issue, but due to the intermittent nature of it we have yet to narrow down the cause. I have a couple of suggestions that might work for your to get around this:

  1. Set the Timeout page to your custom login (via Administration→Configuration→Integration→Timeout Page→Custom (then add your login page name)
  2. Remove sessions timeout (ensuring that Kill Remote is enabled for logging in from multiple systems).

Please let me know if either of these options would work for you, otherwise I will add you to the existing tasks and keep you updated on the investigations.

Cheers,

Neal

photo
1

Hi Dillon,

Hope you're having a good week. I wanted to see if any of the options I provided have helped you work around this?

  1. Set the Timeout page to your custom login (via Administration→Configuration→Integration→Timeout Page→Custom (then add your login page name)
  2. Remove sessions timeout (ensuring that Kill Remote is enabled for logging in from multiple systems).

Please let me know if either of these options would work for you, otherwise I will add you to the existing tasks and keep you updated on the investigations.

Cheers,

Neal

photo
1

Hi Neal,

I'll give this a shot. On item 2, where can I find the sessions timeout? I've looked all over the admin console and don't see an option to control this.

Thanks

photo
1

Hi Dillon,

Sorry, I should have linked this to begin with. The Session Timeout value is set in the /appserver/conf/web.xml by modifying the following block:

   <session-config>
        <session-timeout>30</session-timeout>
    </session-config>
You would need to set the session-timeout value to 0 for the timeout to be disabled. There is a short article here articulating the same.

Please let me know how you go with this.

Cheers,

Neal

photo
1

Hi Dillon,

Hope you are well. I wanted to see if you have been able to work around this issue with the suggestions I posted earlier?

Cheers,

Neal

photo
1

Hi Neal,

We decided we do not want to turn off the session timeout. So, we just ended up deciding we are just going to replace the Yellowfin image on that page with our logo since we can't automatically forward to the custom login page from here.

photo
1

Hi Dillon,

Smart thinking. Please let me know if there is anything else I can help with.

Cheers,

Neal