Manually Entered Date Ordering Issue

Larry Beasley shared this question 17 months ago
Answered

Whenever I manually enter a date range, the range gets reversed so that the lowest date is on top and the greatest date is on the bottom. There is one problem with this. It looks at the month only. I think that it is sorting alphanumerically. I've attached a video that I captured using Jing. It only lets me save as .swf and the only way I could play it back is by using Internet Explorer. If you cannot view it, this is what happens:

I enter in the date range in the following order:

05/31/2016 - 08/01/2015

The logic is supposed to be designed to switch 05/31/2016 with 08/01/2015 because 08/01/2015 is older (less) than 05/31/2016 but it doesn't. Since 08 is greater than 05 it keeps the current order and when I run the report I receive an error message: Max value must be greater than Min value.

If I enter the reverse:

08/01/2015 - 05/31/2016

Then the two dates are switched because 05 < 08 even though the 05/31/2016 > 08/01/2015. This will again result in the previously mentioned error message.

Comments (4)

photo
1

Hi Larry,

I do believe this is related to an existing defect that was fixed in our latest build. What version and build of 7.3 are you on?

Regards,

Mike

photo
1

Hi Larry,

I just wanted to check in and see how things are going with this.

Regards,

Mike

photo
1

Hi Mike,

I can't speak to which subversion we are on as my license is issued by Credible. If this is existing defect then feel free to close this ticket. We have to wait until Credible can patch this but I know this has been an issue for awhile and I wasn't sure if you guys knew about it. FYI I'm also waiting for a patch that fixes the advanced function issue.

photo
1

Hi Larry,

This was indeed completed and published. Upon your having the chance to upgrade, whenever that occurs, if the issue still persists please open a new trouble ticket so we can assist further.

If you're referring to the Advanced Function issue you raised under https://community.yellowfinbi.com/agent/object/9575, that too is indeed fixed in the latest version of 7.3, but if you have further issues regarding that upon upgrading, please respond in that ticket and I'll be happy to assist further

Considering these points, I'll go ahead and mark this as Answered. Please don't hesitate to reach out with further questions or concerns.

Regards,

Mike