JsAPI v3 embeds: reports can be embedded but dashboard denies permission

Sam shared this question 5 months ago
Answered

We finished developing a dashboard and are ready to deploy it to the public. It has three reports in it. When we test those, they embed in our public webpage correctly. But the dashboard itself will not display, the webpage returns a popup "ERROR: Login Required."

The dashboard is in the same folder as the reports. It's marked unsecure. I've tried experimenting with Guest User / Public User permissions in the admin console, none of that seemed to help. Can you advise on what settings we should investigate to solve this?

Comments (4)

photo
1

Hi Sam,


Apologies for the delay.


The pre-requisites for embedding yellowfin content would be to ensure CORS(Cross Origin Resource Sharing), External Base URL, current session of user having access to the content. As you were able to access the reports from the webpage, I believe CORS and External Base URL seem to be pointed correctly. I suspect, the issue would be around the access to the content.

Could you please confirm if the current user has the access to the dashboard. And would also like to know if other dashboards from the same folder work fine?


Regards,

Deepak

photo
1

Thanks Deepak. This is a report that is embedded in a public webpage, I work for a municipal government and am trying to make this dashboard open to the world, without needing a login. My understanding is that the relevant role there is the Guest Access user with the role Public Facing. I can see the reports in a Private window, i.e., not logged into Yellowfin -- but not the dashboard.


To your other question, no, I created another dashboard and put it in the same folder and it yielded the same error: "Login Required". That test dashboard has just a single report which successfully can be embedded by itself.

photo
1

In case it helps, I just made a test Story (also with a working-embed report), put it in the same folder, and it embedded successfully. So it seems to just be something with Dashboards.

Here are some of how I have permissions set for the Public Facing role, the dashboard boxes that are checked are all ones I've tried in an attempt to fix this but they didn't work. Anything look off here?

/8cb9c0f2b81f614ae550a7bbe97d1221

photo
photo
1

Hi Sam,


Thanks for the information.


I believe there are two things here: 1) Setting up the guest user and providing access to content and 2) Could be an issue with SameSite cookie in browser which YF versions older than 9.3 can't handle.

1. To double check the guest user setup and unauthenticated access to content, please refer to the article.

2. If we have a version older than 9.3 (Please look into /info.jsp page to check version), then the possible solutions could be:

a) Upgrade YF to 9.3 or above as they have some built in functionality to handle SameSite.

b) Or if upgrade is not feasible at this time, add some configuration changes as outlined in the article that could resolve the Samesite issue.


And alternatively, could you please try to change v3 to v2 in the script for the dashboard (just a trail to see if we can get around temporarily).

Example: Before change: <script type="text/javascript" src="http://localhost:9620/JsAPI/v3?reportUUID=05aef907-c262-41ed-a9f2-75c36a091920"></script>.


After change: <script type="text/javascript" src="http://localhost:9620/JsAPI/v2?reportUUID=05aef907-c262-41ed-a9f2-75c36a091920"></script>


Please let me know if that helps.


Best Regards,

Deepak

photo
1

Thanks Deepak. The problem has been resolved. I'm not positive how. As best I can tell, it was one of those dashboard settings that did the trick, from my screenshot, and maybe it took a while to take effect (?) so it appeared not to work at first.

At any rate, I'm set on this one and you can close the issue, thanks.

photo
1

Hi Sam,


Thanks for the confirmation.

These settings apply as soon as we hit the save button. Not sure why it took some time to apply. I guess, there might be some other action performed that allowed access to the dashboard.


Anyway, I am glad that it got fixed. I will mark this as resolved for now.

Please feel free to reach out if there are any issues.


Warm Regards,

Deepak