JDBC connection using Oracle Wallet with Yellowfin

Abdul Malik Mansoor shared this question 1 year ago
Answered

Hi,

Is it possible to use oracle wallet instead of username/password to set the database in web.xml?

Is it possible to use something like

<init-param>

<param-name>JDBCUrl</param-name>

<param-value>jdbc:oracle:thin:/@DEV_DB</param-value>

</init-param>

<init-param>

where DEV_DB is the database alias and then leave the JDBCUser, JDBCPassword empty, and set JDBCPasswordEncrypted to false. So far i haven't been able to get this to work - any suggestions would be helpful.

Best Answer
photo

Hi Abdul,

at the moment Yellowfin doesn't support the Oracle Wallet, however please feel free to raise this functionality as an Idea.

If you wish to connect to your Oracle Yellowfin configuration database via SSL you can try the following steps (I haven't ever tried it myself but it should work):

1) Add the following to your catalina.bat / catalina.sh file, or your service settings if you are using a windows service

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.keyStore=/applications/apache-tomcat-5.5.32/keystore”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.keyStorePassword=password”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.trustStore=/applications/apache-tomcat-5.5.32/truststore”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.trustStorePassword=password”

2) and then update the JDBCUrl in the web.xml file (<yellowfin>\appserver\webapps\ROOT\WEB-INF) so that it contains the correct JDBC connection string that has the SSL switch.

regards,

David

Comments (2)

photo
1

Hi Abdul,

at the moment Yellowfin doesn't support the Oracle Wallet, however please feel free to raise this functionality as an Idea.

If you wish to connect to your Oracle Yellowfin configuration database via SSL you can try the following steps (I haven't ever tried it myself but it should work):

1) Add the following to your catalina.bat / catalina.sh file, or your service settings if you are using a windows service

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.keyStore=/applications/apache-tomcat-5.5.32/keystore”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.keyStorePassword=password”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.trustStore=/applications/apache-tomcat-5.5.32/truststore”

JAVA_OPTS=”$JAVA_OPTS -Djavax.net.ssl.trustStorePassword=password”

2) and then update the JDBCUrl in the web.xml file (<yellowfin>\appserver\webapps\ROOT\WEB-INF) so that it contains the correct JDBC connection string that has the SSL switch.

regards,

David

photo
1

Hi Abdul,

I am just wondering how you are getting on with this ticket?

regards,

David