Is there a global setting to change language to English for all users?

Vandana Jagtap shared this question 5 months ago
Answered

Hi,

Customer has installed Chinese browser and they want to set default language in YF to English. They can't change browser language to English.

Advised them to configure as below-

1. Add English language in Administration > Configuration > Region tab, expanding the Language Settings section

2. Navigate to user's Profile Settings and add English as Preferred Language

With Above steps, the user can see contents in English in YF. But they dont to set it for all users manually and want to know if there is a global setting to do it for all users in one go.

Regards,

Vandana

Comments (14)

photo
1

Hi Vandana,

Yes, this is possible, with a change to the configuration database. Bear in mind that this will change all of the instance's client languages to the chosen language.

https://wiki.yellowfinbi.com/display/yfcurrent/Advanced+Configurations#AdvancedConfigurations-Enforceagloballanguage

So for UK English it would be

INSERT INTO Configuration VALUES (1, "SYSTEM", "OVERRIDE_LANGUAGE", "en_GB");


I hope that helps!

Kind regards,

Chris

photo
1

Hi Vandana,

Hope you're having a good week.

Just wanted to check-in and see how it's all going. Was there anything you were needing from me to help get this resolved?


Kind regards,

Chris

photo
1

Hi Chris,

Thanks for following up.

I have followed up with customer but they haven't replied yet. If they do come back with ant queries, I will let you know. But for now, you can close the topic.

Regards,

Vandana

photo
1

Hi Vandana,

Thanks for letting me know. Enjoy the rest of your week! :)

Kind regards,

Chris

photo
1

Hi Chris,

Customer has come back saying the configuration is not working as expected and users still see simple Chinese.

They use Chinese browser and they have executed below query. But user still see simple Chinese when they login to Yellowfin. Any advise please?

INSERT INTO Configuration VALUES (1, 'SYSTEM', 'OVERRIDE_LANGUAGE', 'en_US');


Regards,

Vandana

photo
1

Hi Vandana,

It looks like there's block on the below change if multi-language is enabled on the Yellowfin server. You should disable this first and then restart the Yellowfin instance. Let me know how that goes.

Kind regards,

Chris

photo
1

Hi Chris,

Customer disabled Multi language setting and restarted the server but they still see the simple Chinese. Please advise. Or should be setup a screen share meeting with them?

Regards,

Vandana

photo
1

Hi Chris,

Just checking if there is any update?

Regards,

Vandana

photo
1

Hi Vandana,

Please could you send over a screenshot of what the customer sees in Yellowfin after running the query mentioned below.

Here for example, I have run the same query on my Yellowfin configuration database, with the browser set as French, restarted Yellowfin and now it displays in English. Bear in mind this won't affect the language of the content, only the Yellowfin interface.

/d661ebb2a4e44aff53fb5043e11eafab

Could you also send a copy of the info.jsp page.

Kind regards,

Chris

photo
1

Hi Chris,

Sorry but I didn't understand, which query should customer run? I can see you are running a Dashboard but I didn't get which query.

Yes customer is wanting to see Yellowfin interface in English with Chinese browser.

I will ask for info.jsp

Regards,

Vandana

photo
1

Hi Chris,

Please find attached sysinfo xml

Regards,

Vandana

photo
1

Hi Vandana,

This is the query, to be run on their Yellowfin database repository. It might be best to try en_GB here. Then restart Yellowfin. Then please send over a screenshot of what the user sees.

INSERT INTO Configuration VALUES (1, 'SYSTEM', 'OVERRIDE_LANGUAGE', 'en_GB');

They will need to make sure their user profile settings look like the below as well:

/b1ada0cf44ebff5e202366efb2fdd8a1

Kind regards,

Chris

photo
1

Hi Vandana,

Hope you're having a good week.

Just wanted to check-in and see how it's all going. Was there anything you were needing from me to help get this resolved?


Kind regards,

Chris

photo
1

Hi Vandana,


I hope things are going well over there.


Just wanted to let you know I'll be closing this request due to inactivity. However, if you ever wanted to re-visit this or have anything else I can help you with, please let me know.


Regards,

Chris