Installer does not recognize Java 9

Stephen Van Rooyen shared this question 2 years ago
Answered

Hi Guys,

The installer does not seem to recognize Java 9, had to install Java 8 for installer to work.

Using the latest installer for v7.3+, yellowfin-20170908-full.exe

Error:

This application requires a Java Runtime Enviroment 1.0.0.

Regards,

Stephen

Comments (4)

photo
1

Hi Stephen,

I hope all is well,

Thank you for bringing this to our attention. As Java 9 has only just been released, we developed our 7.35 20170908 patch to be compatible with Java 8. This is something I have raised with our support/dev team to see what actions are being implemented with regards to our future releases of YF. I will update you as soon as I get news.

I hope this is ok and once again thank you for making us aware.

Regards,

Mark

photo
1

Hi Mark,

Thanks for the feedback, just on that note.

Its not just the installer, Yellowfin itself also cannot startup using Java 9

Error:

java.lang.LinkageError: You are loading old SAAJ from jar

Regards,

Stephen

photo
1

Hi Stephen,

Thank you for the update. I will update this to my team. I will also test myself to see in person.

Regards,

Mark

photo
1

Hi Stephen,

Further to my last post, we can confirm that this is something we will work on, this has since been logged in JIRA for our Dev team to look at.

Regards,

Mark