How to use calculated total on an advanced function?

Rose Craig shared this question 3 years ago
Answered

Hi, I am wanting to have a total for the column % compliant. The field is calculated by using the advanced function and division of columns No. compliant SKUs / No. Core Range SKUs.


I have selected to use 'Calculated Total' however this leaves the total blank.


a58a03835abb0820208b66beb57da357


I believe my question is very similar to what was discussed in this forum here http://www.yellowfinbi.com/YFForum-How-to-get-the-Calculated-Total-in-Report-Output-?thread=170412


However, the answer suggested here states to use an append and sub query but as my report is a drill anywhere report this is not a suitable solution.


Thanks

Rose

Comments (4)

photo
1

Hi Rose,


Thank you for getting in touch. Calculated totals apply primarily to calculated fields rather than advanced functions.


In this case I would recommend creating this field using a calculated field with the same equation as your advanced function, and then selecting the calculated total option.


Please let me know if this solution does not meet your needs, or if you have any additional questions on this matter.


Regards,

Nathan

photo
1

Thanks, your solution worked!

photo
1

I am also having issues with this. I am needing a calculated total from Sub-Query/Master-Query calculations. It doesn't work, even if I create a calculated field.


-Zack

photo
1

Hi Zack,


Thanks for reaching out. In what looks like a huge coincidence, I see a very old developer task, that might have gotten this fixed in version 9.3!

Resolved an issue where calculated totals were using data from the wrong sub query 


The official release is still a bit off (days), but I could check to see if one of our betas includes this fix. Would you be in a position to test functionality in a new version if I could provide this? I can do a replication here too, but I'd like to make sure there isn't some additional parameter or configuration in your environment that we need to account for. It might be okay to just wait a couple days for the release too. But I would like to get this checked out in 9.3, in case it fixes everything for you! Let me know what you think.

Thanks,

Eric


Thanks,

Eric

photo
1

Eric,

Yeah! That would be great! Let me know and I will do what I can to help! I am not sure how many "days" it is away... so if it is more than I few, we can load it on our dev and do some testing!


Thanks,

Zack

photo
1

Hi Zack,

I sent you an email about the beta, hope it helps get things working for you. If 9.3 proper doesn't resolve this, shoot me a reply and I can split this off into a separate ticket.

Thanks,

Eric

photo
1

Eric,

I am still having issues...


-Zack

photo