How to remove blank spaces from file that uses - Append Broadcast date

Tim Jordan shared this question 4 months ago
Answered

We set up SFTP broadcast to send drop a file on a Centos (Linux) server, this is working fine, however, we notice when we checked "Append Broadcast Date", the date was append fine, but it left blank spaces.

We have:WebTeamHRISProjectReport - 27 Mar 2020.csv

For example, we wanted our file labeled:WebTeamHRISProjectReport-27-Mar-2020.csv

I'm sure blank spaces for a file name is fine on a Windows machine, however, on a Linux machine, this isn't recommended.

Do you have a solution or workaround for this? Is there a configuration setting in the GUI settings we're not seeing?

Thanks!


041985caf1ca648cff95f2692f80b4ee


92006c09717372cb61100ed7190d63cd

Comments (2)

photo
2

Hi Tim,

Thanks for reaching out to support with your question. Unfortunately it is not possible to change the filename formatting of the date in FTP broadcasts at this point, but we do have an existing developer task that aims to allow these spaces to be removed from the filename in future versions -

https://community.yellowfinbi.com/topic/customisation-of-report-names-for-ftp-schedules

If you'd like to give this task additional visibility, give this Idea a "thumbs up." You can also subscribe to the Idea post to receive updates to this Idea if desired. Hhopefully this answers your question?

Thanks,

Eric

photo
1

Hi Tim,

Hope you are well. I'm going to go ahead and mark this question as Answered at this time, please refer to the aforementioned Idea post for future updates in regards to this functionality.

Thanks,

Eric