How to activate Freehand SQL option in calculated field

Priscilla T shared this question 12 days ago
Answered

Hello,

I have enabled ‘Allow Freehand SQLCalculated fields’ in Administration\Roles\Functions\Report Builder, however the Freehand SQL option did not show up in the formula type on the calculated fields.

/AwM8k+DcDyWdAAAAAElFTkSuQmCC


/PwW3ZjdldB15AAAAAElFTkSuQmCC

Could you please let me know if any more setup is needed? Any assistances would be greatly appreciated. YF version: 7.1 build: 20150729


Thanks,

Priscilla

Comments (1)

photo
1

Hi Priscilla,


Thank you for reaching out to us on this. Changes to these settings require a user to log out and log back in for the changes to be applied, can you please confirm that this has happened?


Cheers,

Neal

photo
1

Hi Neal,


Thanks for your reply. Yes, I can confirm that log out and log back have happened. Would there be any other setting I missed?


Thanks,

Priscilla

photo
1

Hi Priscilla,


Sorry for the short email earlier, I have done some more digging and the other setting that can affect this is the Source Security on the Data Source itself. If it is set to Secure (which by the sounds of this behavior that is the case), you would need to add that user to the Access List for that Data Source. To do this go to the Admin Console and click on the Data Source you want them to be able to write Freehand SQL. Select the 2 on the top menu (highlighted in the purple box) and then click on +Add people or groups (highlighted in the green box as shown below:


763cc7c06567d0a1e58ccaf7e0a5cdf7

Then select the permissions as needed (most likely Update, unless you want to grant them access to Delete the data source connection as well)

d5d7071ec44379265a4a00bb948bd96f

Please be aware that the Update settings allows that user to:

  • To Create, Edit, or Copy a Freehand SQL Report based on the Data Source.
  • To Create, Edit, or Copy a View based on the Data Source.


Please let me know if this resolves your issue or if there is anything else I can do.


Cheers,

Neal

photo
1

Hi Neal,


I followed your instructions and it resolves my issue. Thanks so much for your help!


Cheers,

Priscilla

photo
1

Hi Priscilla,


Great news, if you have any further issues please do not hesitate to reach out to us.


Cheers,

Neal

photo