How do I enable caching on a view?

Ryan Carrie shared this question 2 years ago
Answered

How do I enable view caching?


I've set a default cache period in the View Options but I can't find the "Cache" tab in View Summary.

Comments (5)

photo
1

Hi Ryan,

When caching a view, you're caching the result set of that view into another data source.

So this could be a local database, or the Yellowfin in-memory database.

In any case, unless you have a 'writable' data source, you will not have the option to cache any views.

8081afcbfd8e7824438eda1fcc167b17


Regards,

David

photo
1

Hi David ,

My question is almost the same. I cannot see cache option in view summary. My requirement is to cache view data every morning at a fixed time. I am also not able to see 'Writable' option under Access filters Can you please help me with steps to configure this. I am using version 7.4

I have added screen shots for reference.

Thanks,Sumit

photo
1

Hi Sumit,

Thanks for your reply. You will need to look under 'Usage Parameters' for the 'Writable' option:

8081afcbfd8e7824438eda1fcc167b17

Access Filters will not contain this.

Thanks,

Ryan

photo
1

Hi Ryan,

Thanks for your reply. I was able to turn on Writable function for 2 connections but for the 3 connection - JumpRamp Redshift it was not present . Is there something we are are missing to make this connection writable?


Thanks,

Sumit

photo
1

Hi Sumit,

Thanks for the reply. I've submitted this as a private ticket for you so that we can work the issue. Someone with Support will be in contact via that ticket as able.

Thanks,

Ryan