Hide secondary y axis

Elsie Lam shared this question 4 months ago
Answered

Hi. How do I hide the secondary y-axis from the chart? There is a toggle in the Axis Settings that lets you hide the primary vertical axis but there isn't any for the secondary vertical.


I want both vertical axis to be hidden in the chart so it appears clean.


Thanks.

Comments (2)

photo
1

Hi Elsie,

I hope all is well,

As you have stated, there is an option within the vertical axis settings when editing your chart. (see below)


404e24652272891073dc342266543252

I have tested this in the latest version (8.0.2 20190702) and I can confirm that turning the visible switch to off, will disable the vertical axis on the chart, including both vertical axis when using combination charts. (see below, Vertical Axis both on and off).


Vertical Axis turned off


7d31d1dd2ddcee805708477e95c08f8a

Vertical Axis turned on


d0290bafb6afee2edc2716523efa7005

If you are find that this isn’t working as shown above, please could you provide us with the following information;


  • A screen shot of the current output when this switch is off.
  • The type of chart you are using e.g. Combination, Bar, Line, etc. (This will allow for us to more easily replicate your example)
  • The version and release of Yellowfin you are using. (This allows us to build the same chart in the same environment)

I look forward to your reply.

Regards,

Mark

photo
1

Hi Mark,


I've attached what I'm seeing with vertical axis ON and OFF. I could just be my version of Yellowfin but only the primary vertical axis gets hidden with the toggle.


I'm using a combination chart with the line on the primary vertical axis and the stacked bars on the secondary vertical axis.


Here's the Yellowfin environment I'm using:

Application version: 8.0.1

Build: 20190527

Java version: 1.8.0_212


Is it because the toggle only works for both axis from 8.0.2 onwards?


Thanks,

Elsie

photo
photo
1

Hi Elsie,

Thank you for providing some additional information, with this I have gone ahead and built a similar report/chart to that of yours, see my findings below:

I added the appropriate data then continued on to the chart step to which I selected Overlay Chart.

Having set my chart up we can then see that you are absolutely correct with the fact that we CAN'T "hide" the Secondary Axis (Vertical). From what we can see this is only an option for our main Vertical Axis.

You can see my examples below showing this:

On

1d2d9cec6889fafe439461a1dacc3b67Off

c7d3f3f45cbe888480d8c8a1725a55a5

I can then confirm that this is intended design behavior, this would then propose me to say that we could raise and idea for this? is this something that you are interested in?

Looking back at my original response, I set that up by using the Combined Category, to which turning the Visibility off, turns it off for both individual charts although this was the main Axis as this chart does not contain a secondary. See below:

On

d3f07b2a99a09f971f11553b1c4dacd4Off

c9521e16d7d08f3770167d1e2e9e02ffRegards,

Mark

photo
1

Hi Mark,


Happy for this to be raised as an idea.


If the tool currently provides a toggle to hide the primary axis, it only makes sense that the toggle be made available for the secondary axis as well. And the toggles should be independent of each other because data that needs to be plotted on 2 different axis are generally on vastly different scales.


Thannks,

Elsie

photo
2

Hi Elsie,

I hope all is well,

I have gone ahead and raised this as an Idea, we can track this here.

Regards,

Mark

photo
1

Thanks Mark.

photo
1

Hi Elsie,

No problem, I will go ahead and mark this Question as Answered, any further communication can be held within the Idea ticket.

Have a great week ahead.

Regards,

Mark

photo