Export to excel fails

Daniel Marrujo shared this question 4 months ago
Answered

Details:

we have a report with a co-display divided in 2 tabs,

- First report is a summary that runs real quick. 5 to 10 rows, 3 columns

- Second report has detailed information. 100-200 rows, 3 columns. however it takes like 5 min to run


If we run the Detailed report (click on the Details tab Report) on the UI there is no issue we get the data after 5 min, then we are able to export to Excel because the data is already in there export is really quick, however if we are on the summary tab and try to export to excel smart reportng will run the detailed report to then export it (Please correct me if I'm wrong). On this last step sometimes we get the excel file and sometimes we just get a generic browser error:


This page isn't working

Host didn't send any data.

ERR_EMPTY_RESPONSE


Question here is, do you know if there is a wait timeout for an Excel export?, because from the UI even if it takes 5 min to run we get the results every time.


I already check the memory and in all the export process we always have 4 free GB available.

Comments (9)

photo
1

Hi Daniel,

Thanks for reaching out. What version/build of Yellowfin is this? The report is going to be run before exporting, so if the report itself takes around 5 minutes to load you're probably running into a default data source timeout. Might be able to tell more and/or confirm this if you provide logs. There is also a hidden Advanced Configuration to conserve memory during export, which you can find here. If you execute this INSERT INTO statement then restart YF and re-attempt this, the exporter will use less memory, thus decreasing the time to export and making it so you don't hit the timeout. This would probably be a good place to start.

Regards,

Mike

photo
1

Thanks for the inmformation, this config is just for broadcast right? we are hitting this error while doing a normal export from the report. Please help me to confirm.


Regards,

Daniel M.

photo
1

Hi Daniel,

Nope, this is just for exporting. To make it explicitly clear, I'm referring to this INSERT INTO statement:

/ed9da46a6388a07fc8a3aff5c0491d7c

Regards,

Mike

photo
1

Hello,


After several testings this option do not help that much, after debugging this issue we find out that smart reporting actually finish the export, we get the name of the file and size on the smartreporting.log (yellowfin.log) on debug mode. no errors on logs.


Also we notice that the successful rate is higher on IE that in chrome, I found an article related the browser error (chrome) but do not help that much.


https://blog.pcrisk.com/windows/12807-err-empty-response


Any guidance will be really appreciated.


Regards,

Daniel Marrujo

photo
1

Hi Daniel,

Thanks for your response. It sounds like something else could be going on here then. Can you indicate the timestamp of one of these export attempts and also provide an updated compressed copy of your entire logs folder containing said timestamp, located at <YellowfinInstall>/appserver/logs so we can investigate further? You can upload these to our FTP site here, if the file's too large.

Regards,

Mike

photo
1

This is the name of the report:


DWP - Order Oracle Server Software License


Attaching logs folder to ftp, file name: Tomcat_Apache_SmartReporting_logs (1)

photo
1

Hi Daniel,

Thanks for providing this. I can see the .xlsx file is indeed generated here. The thing is, even with the low memory export option, the exporter still has to wait for the report to run before exporting to .XLS. So yes, if it generally takes about 5 mins to run the report itself, it's plausible that with the extra process of exporting it's putting it just over that timeout making it so that the export doesn't occur. It's also easily possible there would be slight differences in execution time between browsers and in this case, with the report runtime being near the default JDBC Timeout between application and configuration database, it's likely that sometimes that just puts it over the timeout when exporting in Chrome.

Ultimately, to rectify this you'll want to update the JDBCTimeout parameter in your web.xml file. You can reference the following article here: How to Increase the Connection Timeout to the Yellowfin Database.

Please let me know how goes and if you have any additional questions.

Regards,

Mike

photo
1

Hi Daniel,

I just wanted to check in and see how things are going with this.

Regards,

Mike

photo
1

Hi Daniel,

I'm going to go ahead and mark this one as Answered since I haven't heard back from you, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike