Disable Chart brushing on SubTabs

Carl Edwards shared this question 11 months ago
Answered

Hi,

Disabling brushing on a chart within a sub-tab seems to have no impact YF 9.3.0. I need to switch the brushing option off whilst maintaining the Auto Analysis option.

The chart is a line chart, nothing fancy.

if you follow the series on the screenshots, you'll see i start with brushing on, disable it in the dashboard for that chart, then publish the dashboard and look again - brushing is still available.

Any ideas on how to disable this?

Thanks

Carl

Comments (6)

photo
1

Hi Carl,


Thanks for your message.


I've gone ahead and tested this behaviour out on Yellowfin 9.3.0, and can confirm that this is a defect. The good news is that this has been resolved in later versions of Yellowfin, where the most recent version (9.4) does not exhibit this behaviour. If possible, I would suggest upgrading to 9.4, downloadable from the Support Centre. Otherwise, to work around this you will have to disable or enable Chart Brushing globally on the Dashboard.


Let me know if you have any further questions.


Kind regards,

Simon

photo
1

Thanks Simon, I'll give it a whirl in 9.4 and come back to you.

photo
1

Hi Carl,


As this issue has been confirmed to have been resolved in version 9.4, I will go ahead and mark this ticket as closed.


If you require further assistance with regard to this issue, please don't hesitate to respond here to re-open the ticket, where I will get back to you shortly.


Kind regards,

Simon

photo
1

Hi Simon,

Many thanks, I've tested with a number of different setups (all in 9.4.1) and can confirm the issue is indeed resolved.

Cheers

Carl

photo
1

And it's back again in 9.5.0 Not had a chance to test in 9.5.1

Can someone confirm/deny if disabling the brushing on a dashboard works in 9.5.1

photo
1

Hi Lex,


I've gone ahead and attempted to replicate this on 9.5.1, however, it still seems to work the way it's meant to. Brushing is toggled on a Chart by Chart basis rather than a global Dashboard setting, are you certain that you are disabling brushing for each of the Reports you are checking?


Despite all of this, I strongly recommend upgrading to 9.5.1 due to a defect that was resolved.


Let me know if you have any further questions.


Kind regards,

Simon

photo
1

Pretty sure this isn't user error tbh chap. On the dashboard, report widget options, interactions, disable brushing. Exactly the same as the images attached to OP.

Tried running the 9.5.1 update..no joy, null pointer exception see attached log. I'll try a fresh install when I get some time.

photo
1

Hi Lex,


I've gone ahead and created a new ticket on your behalf where we can address the upgrade issues separately.


I haven't been able to replicate the Chart Brushing issue in 9.5.0 nor 9.5.1, indicating that the issue may be related to the issue you are experiencing with the upgrade. If it's alright with you, we can continue looking into these issues separately.


Kind regards,

Simon

photo
1

Hi Simon,

Finally got around to installing 9.5.1 and have some more info for you...it appears to be a similar issue to the one where elements were appearing on the wrong subtab. I created a dashboard with 4 subtabs and put the same 2 reports on each subtab, one with the brushing interaction enabled and the other with it disabled. On the first subtab, this worked perfectly...on every other subtab, the brushing interaction remained available even though it had been disabled in the widget options.

See video here

photo
1

Hi Lex,


I've gone ahead and replicated this issue, and reported it to Developers.


I have created a separate post here to continue correspondence and keep you updated. I kept the post public for the benefit of the wider Community, feel free to let me know if you would like it moved to a private post.


For the moment, I will go ahead and keep this post closed.


Kind regard,

Simon

photo