Disable autorun

Pratap Singh shared this question 40 days ago
Answered

Hi,

I am looking for a possibility to disable this option for all reports once,

it will be a time-consuming task if we will do this one by one for all the reports.


/1b3ace41fa2c89981569f0b7e2cc39e4


Thanks & Regards

Pratap

Replies (2)

photo
1

Hello Pratap Singh,

Thank you for reaching out to the Yellowfin Support Team.

While we are investigating this issue, could you please let us know the exact version and build of Yellowfin you are currently using so that we can replicate the same and get back to you with the findings.

Regards,

Yamini Naidu

photo
1

Hello Pratap,


Go to Administration>content setting>report setting

58637b9fd0bd02c5096c3cbf86f469de


Turn off the option labelled "Autorun Report with Filter" here.

Save the setting after that.


Let's attempt it and see

If that works for you, let me know.


Regards,

Yamini Naidu

photo
1

Hi Yamini,

I suppose this setting is being overlapped by the already set value at the report level. it can be helpful for all new reports but not for the existing reports which are already there with this setting on.

/555a2df99bff6f980510487f6e0bb2b7


Regards

Pratap

photo
1

Hello Pratap,

Yes, you are absolutely right.

We investigated and found that with this setting on, it will only be useful for any brand-new reports; it won't help with any already-existing reports.

If you would like, we can raise an idea to the development team for this kind of issue.

Let me know your thought on this

Regards,

Yamini Naidu

photo
1

Hi Yamini,


I understand that, but is there any quick alternative for this from the backend?

as i can see reportformat table have one setting formattypecode = 'WAITFORPROMPT'

maybe i am missing something , if possible can we check that option?


Regards

Pratap

photo
1

Hello Pratap,

Allow me some time, let me investigate this more and get back to you with the findings.

Regards,

Yamini Naidu

photo
1

Hi Yamini,
Any update?
Regards
Pratap

photo
1

Hello Pratap,

Sorry for the delay in responding.

Hope you are doing well

This is to let you know that a task has been created for the product team so they can provide an update on your concern.

As soon as we receive a response from them, we'll let you know.

Regards,

Yamini Naidu

photo
1

Hello Pratap,

Wish you a very Happy New Year

Thank you so much for your patience

Regarding your concern, we received a response from the wider team, and have shared us the below updates for your reference

This is a bit difficult because WAITFORPROMT = FALSE is implied by default, so there are no WAITFORPROMPT records (unless someone has turned it on or off)

The script below will add the WAITFROMPROMPT option for every report in the system (whether they have filters or not) if they don't already have a WAITFORPROMPT record.

INSERT INTO ReportFormat
SELECT ReportId, 'TITLE' AS EntityCode, 0 AS EntityId, 'WAITFORPROMPT' AS FormatTypeCode, 'TRUE' AS FormatCode, 0 as FormatValue , NULL AS Description, 0 AS FieldId, 0 AS ChartId , 0 AS SeriesId, null AS AxisCode
FROM ReportHeader
WHERE RoleCode = 'OPERATIONAL' AND ReportStatusCode = 'OPEN'
AND ReportId NOT IN (SELECT ReportId FROM ReportFormat WHERE FormatTypeCode = 'WAITFORPROMPT')

(This is PostgreSQL syntax and may require changes for other repository databases)

As always, I suggest that a backup of the Repository database be taken before running this query. Yellowfin should also be restarted to flush any caches that might hold the pre-query settings.

I believe this will be helpful for you, please let me know.

Regards,
Yamini Naidu

photo
1

Hello Pratap,

Hope you are doing well.

I just want to touch base to see if you had chance to read through my response. If you can let me know that would be great. Thank you!

Regards,

Yamini Naidu

photo
1

Hello Pratap,

I just want to touch base to see if all is well, if you can let me know that would be great. I look forward to your reply.

Thank you!

Kind Regards

Yamini

photo
1

Hello Pratap,

Hope you are doing well.

As there is no revert back from you and because of age and inactivity I am going to go ahead and mark this ticket as closed for now. If you wish to re-open and discuss further I will be more than happy to do so.

Thanks!

Regards,

Yamini Naidu

photo
Leave a Comment
 
Attach a file