Session timeout not working

PETER WOHLKEN shared this question 56 days ago
Answered

Periodically, we reach our maximum of concurrent sessions, and everyone is locked out with this message: This system currently has the maximum number of concurrent users logged in.

However, the real problem seems to be that closed sessions are not being cleared. The number of rows in the ACTIVESESSION table equals our concurrent license count, even though few of these rows actually represent active users.

Note that this takes a while to develop; after restarting the service, Yellowfin will run okay for several weeks.

Is there some configuration change that I can make to help Yellowfin be more reliable? Our session-timeout setting in web.xml is set to 30 minutes (but seems to not be working.)

Also, I was thinking of creating a scheduled task that would delete all rows from ACTIVESESSION during the night. Would that help with this issue, or just create more problems?

Comments (2)

photo
1

Hi Peter,

Usually the session timeout parameter will work, with the exception of using dashboards that auto-refresh. If users have dashboards with this setting enabled, then it would theoretically be possible to eventually accumulate enough active sessions to hit your limit.

There is an enhancement logged already to create a proper session timeout for auto-refreshing dashboards.

That said, it should be possible to clear the sessions via your script, if you know that the system is generally not in use during the early hours. I would test this with a user logged in mid-report creation and having their session row deleted from the table just to make sure it doesn't cause any corruption.

Let me know how that goes.

Kind regards,

Chris

photo
1

Hi Peter,


I hope things are going well over there.


Just wanted to let you know I'll be closing this request due to inactivity. However, if you ever wanted to re-visit this or have anything else I can help you with, please let me know.


Kind regards,

Chris