Can I use two different periods for the default range on a date filter?

Sam shared this question 5 months ago
Answered

What I want to do is show by default the prior 4 weeks of data. So I do this:

/a7690c9005a71f94eb42148c6e589c9b

But after I X out, it reverts to a single unit, in this case Minutes. No data is displayed and then I click back to that same Format screen and it's now:

/0baee2c0c6841cb5112240ea7ce6edfc

Ideally I could specify two different units. If that's not doable, it would be nice to have "Now" as an option for the current date.

Comments (7)

photo
1

Hello Sam,

I can confirm that it is not possible to select two different increments in the default values. Once you choose a different increment it should change the other. Please see attached screen recording. Unsure why this would be a little different in your environment.

I'm happy to help get you where you need to go. What is the end goal that you are trying to achieve? I would like to help you get the output you need, even if it can't be done that specific way.

David

photo
1

Thanks David. I don't see an attached screen recording but I believe you. Things may be wonky in our self-hosted YF configuration (9.6), it has been hard to file fully reproducible bug reports. It would be nice if the change in units applied immediately, but it sounds like that's just a problem on my end.

I wanted to show, by default, the prior 4 weeks of data. So specified the range of Current Date minus 1 Minutes back to Current Date minus 40320 minutes - which is the number of minutes in 4 weeks. That approach seems to be meeting my needs.

The immediate-changing units would mostly address this behavior, which perhaps I should have called a Feature Request. Mixed units, or a "now" option, would be nice, but not essential given the other possible features that could be implemented.

(I am having a separate issue that prohibits me from using the preset 'Last 4 Weeks' defined period, but I have a support call scheduled later today to discuss that one. If that succeeds, I might also be able to take that approach).

photo
1

Thanks for getting back to me. Is there anything more I can do for you right now?

photo
1

I'm set for now, thanks David. You can close this ticket (or log it as an idea, if two units might be a possibility in the future).

photo
1

I can definitely run it up the chain and see if that is something that we can do. I created the Idea in our Community, please take a look at it and add any details that you think will be helpful : Allow different time units for default values

What ended up happening with your inability to use the default last 4 weeks preset?

photo
1

Thanks David, that looks good!

Re: the default last 4 weeks preset, I had a good troubleshooting call with Deepak on Thursday last week, we fixed the issue. I had linked filters on a dashboard automatically, and when it behind-the-scenes populated the filter variable for the report that didn't already have one, it did so incompletely. But I'm good now.

photo
1

Thank you for the update. I'm glad you're up and running!

Please let us know if there is anything else we can help you with.

Have a great day!