Users not able to see content on alternate logins.

Carl Edwards shared this question 17 days ago
Awaiting Reply

This is a weird one.

On login number 1 the user can see the content. if they log out and then log in again they cannot see the content. When they log out and log in again they can see the content.

Follow the loop and they alternate between no content and content.

We've checked groups, roles, permissions, nothing changes between logins.

The Yellowfin version in 9.9.0 running on Tomcat 9.0.87

I'm at a loss, it makes no sense.

Replies (1)

photo
1

Hi Carl,

I hope you're doing well.

Do the users happen to belong to LDAP groups and log in using LDAP authentication? We've had a recent bug where content and content folders appear and disappear on alternate logins.

Let me know.

Kind regards,

Chris

photo
1

Hi Chris,

Interesting!

Yes LDAP users.


Any ideas what the bug is and a way round it?

thanks


photo
1

OK yes that's the key.

We've created a local user and now can see content everytime we log in.

Now i suppose we need to work out a fix for the LDAP issue.

photo
1

Hi Carl,

No worries. Yeah, this one is fixed in 9.12.0.1 which was just released a few days ago. You can check the release notes over here.

Let me know if you're able to test an upgrade and how it goes, if so.

Kind regards,

Chris

photo
1

Thanks Chris,

We'll apply that and test again.

I'll come back with a positive or negative.

photo
1

Great, hopefully it works! :)

photo
1

Hi Carl,

Hope you're doing well. Just checking in here to see how it's going. Did the testing go okay?

Kind regards,

Chris

photo
1

Hi Carl,

Just quickly checking in again to see if you had a chance to test the change and whether it worked out.

Let me know.

Kind regards,

Chris

photo
Leave a Comment
 
Attach a file