Floating button filter not working

Geisson shared this question 7 months ago
Completed

Hello, I am performing an embbed integration using the JS V3 API to view dashboards.
On my dashboard, I'm using a floating filter button to display the filters on my page. In the JS API, I enabled the "showGlobalContentContainer" option to display global content on my dashboard, where the filter button is being displayed. Furthermore, I disabled the option in the bar at the top of the page, as the object is not to display this element using the "showToolbar=false" property, below is an example of the url with the parameters incorporated into my page:

<<server_url>>/JsAPI/v3?dashUUID=<<dashboard_uuid>>&token=<<login_token_sso>>}&&showToolbar=false&&showGlobalContentContainer=true


In the image below we can see that the button is shown in the upper left corner.
746c056634c35a8ccadf75aa3be6da9b
During integration, the floating filter button is not being displayed as shown in the image below.
8b9f4d7a7f9104527e82cc3cc0a68ac4
Note: IN other dashboards that have the side filter fixed in the global area, the information is displayed correctly.

8342e5be3134886d738566516016d97e

Replies (1)

photo
1

Hello Geisson,

Thank you for reaching out to Yellowfin Support

I would like to know the following information to look into this further.

1. The current yellowfin version and build you are using.

2. I would like you to provide the replication video from scratch so that I can see how you are performing. In the ftp link provided below, you can share any files or folders. By selecting the upload file option on the ftp link, you can upload the file without logging in.

https://ftp.yellowfin.bi/login?next=/files/User-Uploads


Meanwhile, you can check the below link. We have comprehensive documentation on our wiki that offers step-by-step instructions on how to modify the filter placement in your dashboard. Please click this link to get to the wiki page.

https://wiki.yellowfinbi.com/display/yfcurrent/Dashboard+Filters


Regards,

Yamini Naidu

photo
1

Thanks for the reply Yamini Naidu.

Below is information about the yellowfin version:

Application Version: 9.8.2.2

Build: 20230501

I uploaded it to ftp, but I didn't find out how to copy the link, I'm leaving here the link to the video that I uploaded via Google Drive.

https://drive.google.com/file/d/1eHOcpiAmbRFAy_YQqyA-JP6Lvkslp2kg/view

photo
1

Hello Geisson,

Hope you are doing well!

I appreciate you providing the video and version details. I've replicated the problem, and the link to my replication is provided below. I am able to view the filter option on the embedded dashboard, as you can see in my video.

https://ftp.yellowfin.bi/f/4ee7cdeb128e65b1

Kindly watch the video, follow the same steps, and let me know if you still have any questions. If you need, I'm happy to jump on a call as well. Please let me know your thoughts.

Regards,

Yamini Naidu

photo
1

Hello Geisson,

Hope you are doing well.

I just want to touch base to see if you had chance to read through my response. If you can let me know that would be great.

Thank you!

Regards,

Yamini Naidu

photo
1

Hello, sorry for the delay. We managed to find another solution within albacora to overcome this problem.

Thank you for your attention.

photo
1

Hello Geisson,

Thanks for the confirmation. I'll close this ticket as of now. Feel free to contact Yellowfin Support when ever you have any concern, we would be happy to assist.

Happy Weekend!

Regards,

Yamini Naidu

photo
Leave a Comment
 
Attach a file