Import view not visible despite success message

Scudfest shared this question 8 months ago
Completed

I am getting cases where I import a view along with the connection and folder location and the view is not visible even when the import dialog says successful.

The location folder and connection are created and are visible.

The view is not visible.

Is there a way to see what happened? Or make it visible?

thanks

Replies (10)

photo
1

Hi Scudfest,

Thanks for reaching out to Yellowfin support.

Could you please let us know the exact version and build of Yellowfin you are currently using it would be great if you can provide the info.jsp page?

And also I'm requesting to share the YF logs, by reproducing the issue and please specify the time. You can compress the logs and share it with us in our ftp server

It would be great if you can share the screen recording of the process you are doing and upload it into our ftp server?

https://ftp.yellowfin.bi/files/

Regards,

Sri Vamsi

photo
1

I don't have direct access to get the server files.

Is there something in audit that could help?

I need to figure out how to do a screen cast.

Here's the build specs

System Information
Application Version:9.4.2.1
Build:20211217
Java Version:11.0.9.1
Operating System:Linux 5.10.135 (amd64)
photo
1

Hi Scudfest,

Thanks for your quick response.

We would require logs if anything reflected over there and If possible can you please share the screenshots.

This sounds like it's related to security and user roles.

Can you please check if the datasource is marked 'secure' and if so send across screenshots of the security page.

Also have a look at the role settings for this user (under Data Source & Views) section.

Another thing to try if everything seems to be ok, is to create a new data source connection and then import the views against this data source.

Please let me know your findings.

Regards,

Sri Vamsi

photo
1

While checking your suggestions above I note that the view has a status of private in the source tenant.

I changed this to public and exported again. This time I was able to import and see the view.

So is there a way to get visibility on the original private view? I need to clean up but cannot delete folders due to the invisible view. I am logged in as admin so not sure how to get the invisible view to show up.

thanks

photo
1

Hi Scudfest,

Thanks for your response.

I have found a similar article as per your request as below.

Sometimes a Yellowfin administrator may wish to be able to see all private reports in the system.

Attached is a script to create a stored procedure that will add the administrator's account to all existing private reports so that he/she will be able to access them. (It is for SQL Server, but if you are using a different database you can still get an idea of how to write a procedure from it)

Once you have run the script and thus created the stored procedure, to execute it all you have to do is run the following in SQL Management Studio:

exec sp_Add_PersonId_to_private_report <insert your PersonId here>

and it will give you access to all private reports in the system.

I hope this helps. Please let me know how it goes.

Regards,

Sri Vamsi

photo
1

That looks a bit hard core!
I will have to test this - we use MySQL for Yellowfin databases.

Will do this later.

cheers

photo
1

Hi Scudfest,

Thanks for your response.

Sure, could you please allow me to mark this as completed for now? However you can feel free to re-open if you need any further assistance. I would be more than happy to assist where I can.

Regards,

Sri Vamsi

photo
1

Hi Scudfest,


Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Yeah sure - close for now.

I'll re-open if I have any issues.

cheers

photo
1

Hi Scudfest,

Thanks for your response. If that's all good, I'll go ahead and mark this as complete for now.

Regards,

Sri Vamsi

Leave a Comment
 
Attach a file