Preferred Language Setting

Alena Saveleva shared this question 8 months ago
Completed

Hello,

It appears that the Preferred Language Setting under the user profile is only available for some users. We've ensure that all client orgs were updated to apply to all client orgs. It didn't appear that there are any role settings that need adjusted. Any idea why this is happening? I have a video but it's too large to attach.

Replies (33)

photo
1

Hello Wilson,

Thanks for reaching out to Yellowfin support.

In order to proceed further, would you kindly provide the information below:

1. Could you please let us know the exact version and build of Yellowfin you are currently using it would be great if you can provide the info.jsp page?

2. If possible, can you please compress and share the video with us and you can upload it into our ftp server link in user upload and please specify the name of the file.

https://ftp.yellowfin.bi/files/

Regards,

Sri Vamsi

photo
1

Hi Wilson,

Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Hi Wilson,

This is a follow up reminder, that there has been no activity on the ticket in the last 2 days.

As no activity, it usually means either that you have found the solution for the reported issue or that the matter is no longer relevant.

Without any activity, we assume that the ticket can be closed within 5 days (2 days from now).

If this is not the case, please do let us know how we can be of further assistance.

We would be glad/pleased to assist you.

Regards


Sri Vamsi

photo
1

Hi Wilson,


This email is to notify you that, you have identified the solution for the reported issue or that this ticket can be resolved for now.

As we find no activity, we are going ahead and mark this ticket as Completed. However, if you ever wanted to revisit this or have anything else we could help you with, please let me know.

We would be glad/pleased to assist you.

Regards

Sri Vamsi

photo
1

Hello,

I've uploaded the file. Apologies on they delay. Here is the info.jsp data:

Application Version:9.8.0
Build:20220921
Java Version:11.0.7
Operating System:Linux 4.14.238-182.422.amzn2.x86_64 (amd64)
photo
1

Hi Wilson,

Thanks for your response.

It would be great if you can mention the file name that's uploaded in ftp server.

And also in meantime can you please go through the below article from YF wiki which will help you to change language settings in YF UI.

https://wiki.yellowfinbi.com/display/yfcurrent/Content+Translation

Regards,

Sri Vamsi

photo
1

Screen Recording 2023-06-07 at 2.46.34 PM.mov.zip

I'm not referring to content translation, I'm referring to Preferred Language that is located under each person's User Profile > Regional Settings > Preferred Language setting.

It is only available for some users. Please let me know if there is any issue with the video.

photo
1

Hi Wilson,

I would like to have screen session with you. I'll be available in between 9PM IST to 6 AM IST. Please let me know your available time in between so that I'll share you a meeting invite to discuss further.

Regards,

Sri Vamsi

photo
1

Hi Wilson,

Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Can we do tomorrow at 11pm IST?

photo
1

Hi Wilson,

Sure, I'll schedule a meeting at 11 pm IST. Please join the link below.

Teams Meeting

Regards,

Sri Vamsi

photo
1

Can't delete this. Please ignore.

photo
1

Hello, I'm on the call. It is for 11 IST / 1:30 EST correct? I have a hard stop at 2pm EST.

photo
1

Hi Tara,

Thanks for joining the call.

Can you please let me know multi-language deployment is enabled for the clients. If possible can you please share the screenshot

go to configuration >> Language settings >> multi language deployment

60f98d9a4fc5de7dd2fb2135f5b1ccff

Regards,

Sri Vamsi

photo
1

Hi Tara,


Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Yes it is enabled. You can refer to both the recording I sent and the one that was taken during our call to verify.

photo
1

Hi Tara,

Thanks for your response.

I would like to connect with you to check few things in your YF UI. Could you please let me know your available time to connect with you and discuss on this issue further. I'll be available in between Mon-Fri 9 PM IST to 6AM IST.

Regards,

Sri Vamsi

photo
1

Hi Tara,


Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

I am available at 11 pm IST today, Friday the 23rd.

photo
1

Hi Tara,

Sure, I'll schedule a meeting at 11 pm IST. Please join the link below.

Teams Meeting

Regards,

Sri Vamsi

photo
1

Hi Tara,

Thanks for joining the call.

As discussed, please enable the the configuration>>roles>>content translation and let me know how it goes.

595f321a0b17db6598c3ccc1c613acf2

Regards,

Sri Vamsi

photo
1

Hello Tara,

Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Hello. We will be restarting the instance tonight as discussed, since the roles don't appear to be updating.

photo
1

Hello Tara,

Thanks for your response. Please let me know how it goes.

Regards,

Sri Vamsi

photo
1

The instance was restarted but it still does not work for all roles. Please advise.

photo
1

Hi Tara,

Please allow me sometime to investigate further on this issue. I'll check with our wider team and get back to you with an update.

Sri Vamsi

photo
1

Hi Tara,

Greetings of the Day!

I have created a Jira task to our product team regarding this issue. I'll keep you posted once I receive an update from them.

Regards,

Sri Vamsi

photo
1

Hello Tara,

I hope you are doing well.

We have received an update from our product team. Could you please provide the details as requested below:

I have been working for some time but have not replicated the issue. I have a default and a client organization, so I have played with multi-lang deployment and role configuration but without any success. If you provide me with the exact steps that I could replicate the issue I will be able to do further investigation.

Please check that multi-language deployment toggle is On in each client org, and that at least one non-English language has been added in each client org.

This should not have anything to do with roles or Content Translation, that is a separate concept for translating customer specific content, not the UI.

Regards,

Sri Vamsi

photo
1

Hello Tara,


Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

photo
1

Sri,

I read the response and it did not provide any new details or ask for anything I haven't already provided.

>> "If you provide me with the exact steps that I could replicate the issue I will be able to do further investigation."

- I did a walkthrough twice and provided a recording already.

>> "Please check that multi-language deployment toggle is On in each client org, and that at least one non-English language has been added in each client org."

- We did this step on the call together already.

Generally any Yellowfin issue the support team at minimum looks at logs or config database if they can't replicate the issue, yet no one has even asked for that after 55 days.

photo
1

Hi Tara,

Hope you're having a good week.

I have managed to replicate the scenario on my end. We are not able to see the 'Preferred Language' option in the client org because of the 'Multi-Language Deployment' option (Configuration--> Region -->Language Settings) of that particular client org (In your example - foodies_foodstaff tenant)

Even if we add a language in default org and apply it to all the client orgs like below:

2b9df4b55bce08359701f9457c4dc563


We would still not see the preferred language option in the profile settings if the Multi-Language Deployment of this particular client org is disabled. So, we need to ensure that it is enabled for each client org.

I have created a video recording explaining the scenario: https://ftp.yellowfin.bi/f/eb08446d75377b33

Regards,

Deepak

photo
1

Hi Tara,

If we still don't see Preferred Language even after individually enabling the Multi-Language Deployment for each client org. I think the way forward would be to get the configdb so that we can replicate in house.

Kindly upload it to the FTP: https://ftp.yellowfin.bi/ and share the name of the file uploaded.

Thanks,

Deepak

photo
1

Hello Tara,


Greetings for the Day!

We would like to check, with you if you had the opportunity to read our last response.

Request, you to review and let us know if you have any questions or further assistance is required.

Regards

Sri Vamsi

Leave a Comment
 
Attach a file