In List filter option not available

Mon Rozkiewicz shared this question 49 days ago
Answered

Hi,

I am trying to set up a filter for a chart. The variable I am using is flag which is stored as 0 (N) and 1 (Y). I have tried changing the variable to a reference code (flag).

When I add this variable as a filter it does not allow for In List.

Could someone please help.

Many thanks,

Mon

Best Answer
photo

Hi Mon,


Could you please confirm which version of Yellowfin you are using?


Has the field been aggregated in any way?


Initially, it looks like the problem is that the data is in a metric/ date format, where it might be better to format it as a dimension. Are you able to test this by creating a calculated field with SQL, setting it to the field name? You can then use the calculated field as a filter to see if this changes the behavior. See below for reference.


/317cb146c97e6d6405b14d614d256781


Thanks,

Simon

Comments (1)

photo
1

Hi Mon,


Thank you for your question.


Could you please expand on what you mean that it doesn't allow you to filter 'In List'? Is the option not showing up at all, or are you not getting the expected results?


I have made an attempt to replicate this using sample data with no luck. Is the underlying data saved as a dimension or a metric? This might make a difference if it is saved as a metric.


Let me know how you go!


Regards,

Simon

photo
1

Hi Simon,

The data is saved as a metric, which has worked for another filter.

The In List option is not showing up at all./ca0ec64dec9fde70862c3b561365a8ae

/09c5a05ce85caca37a4c5fea6e655d3a

Please let me know if you require any further information.

Many thanks,

Mon

photo
2

Hi Mon,


Could you please confirm which version of Yellowfin you are using?


Has the field been aggregated in any way?


Initially, it looks like the problem is that the data is in a metric/ date format, where it might be better to format it as a dimension. Are you able to test this by creating a calculated field with SQL, setting it to the field name? You can then use the calculated field as a filter to see if this changes the behavior. See below for reference.


/317cb146c97e6d6405b14d614d256781


Thanks,

Simon

photo
1

Hi Simon,

It worked! Thank you for your assistance!

Kind regards,

Mon

photo
1

Nice!


You should be able to change the data type in the underlying View, so that in future reports you don't experience similar issues.


Simon

photo