Percentage bar not showing in totals and subtotals

mbacul shared this problem 4 years ago
Defect Logged

When using percentage bar format, the bar image is not showing in subtotals and total:


653640d49a0d52913298bb8d6a98ba2e


The image url is src="{{FS:images/bar_yellowdot.png}}", which is not found.


The same report in version 7.1 was displayed correctly.


Thank you!

Best Answer
photo

Hi Miguel,


Thanks for the clarification. With that extra information I was able to quickly replicate this bug and also confirm that this feature used to work in 7.1. I tried a couple of different things including moving bar_yellowdot.png into the customimages directory to try to override the default, but that didn't work. It appears that any subtotal representation of an image (this includes Person Bar and Dollar Bar) is also broken.


I've gone ahead and raised a defect for this issue. The case # for the defect is 234425. Hopefully it can be resolved soon with a fix making it into a fresh Yellowfin build.


In the meantime you could try playing around with the Image Bar Formatter option. Although it does leave a bit to be desired, it may be used as a tie-over until a proper fix is released. I tested this solution on my end, albeit with some admittedly mixed results.


Sorry about the bad news on this one, please let us know if you have any further questions!


-Conner

Comments (2)

photo
1

Hi there,


Unfortunately we have been unable to replicate the issue that you are seeing. If possible, could you post some screenshots that demonstrate how conditional formatting is set up for your columns? That would be great, thanks in advance!


-Conner

photo
1

Hello Conner,


Thanks for your reply. To simplify things, I have made another report, using the Yellowfin General Usage View, so it should be easier to replicate. It shows the different roles with a distinct count of users:


7530e6d7f27bddb3ecc55add807c3ad6


I now edit the column format, and change it to Percentage Bar:


7fbeefb4d5af25ae9f8b153a949015e2


And this is the result:


a4e847e6c4b2b8ca82d803acde983267


No conditional formatting, just the column format.


I hope this helps.


Thank you!

Miguel

photo
1

Hi Miguel,


Thanks for the clarification. With that extra information I was able to quickly replicate this bug and also confirm that this feature used to work in 7.1. I tried a couple of different things including moving bar_yellowdot.png into the customimages directory to try to override the default, but that didn't work. It appears that any subtotal representation of an image (this includes Person Bar and Dollar Bar) is also broken.


I've gone ahead and raised a defect for this issue. The case # for the defect is 234425. Hopefully it can be resolved soon with a fix making it into a fresh Yellowfin build.


In the meantime you could try playing around with the Image Bar Formatter option. Although it does leave a bit to be desired, it may be used as a tie-over until a proper fix is released. I tested this solution on my end, albeit with some admittedly mixed results.


Sorry about the bad news on this one, please let us know if you have any further questions!


-Conner

photo
1

Hello Conner,


Thank you for the information. It is not a critical issue, so in the meantime we can leave the field with a numeric format.


Best regards!

Miguel

photo
photo
1

Hey Miguel,


Just letting you know that this bug is still at the 'In Progress' status in our internal system. Hopefully using the numeric formatter is still working well for you.


Thanks!

-Conner