Javascript errors with Chrome, but not Firefox

Andrew Patterson shared this problem 3 weeks ago
Awaiting Reply

Hi

I have a strange issue in Chrome (and reportedly Opera) where pages and reports don't load correctly.

In Chrome, I get a number of errors in the javascript console - see screenshot.

/B8C2F6ElEotIAAAAAElFTkSuQmCC

When loading with Firefox, these errors do not occur.

This issue occurs on version 8.0.1 and 8.0.2, running on Ubuntu 18.04.

Any thoughts?

Kind regards,

Andrew


EDIT:

While testing, I noticed that if I use the developer tools to Disable cache in Chrome, everything loads correctly. I have tried clearing the browser cache but the problem continues.

Comments (4)

photo
1

Hey Andrew,

Hope you are well!

This is a strange one and not unheard of, unfortunately. There are some features that chrome does not like and/or is unable to process/render properly which can cause problematic! Though as you have already discovered, there are ways of getting around this by using a different browser.

In fact in one case, there is a very specific feature that chrome will not display unless the browser percentage page is 100%! However, there would be no clues of any errors within the browser console :(

These issues usually appear/disappear during chrome updates making the feature incompatible or re-compatible!

Another example of chrome being a little temperamental is right here within the community! previously typing into the comment box within the community worked as expected but since their last update we are no longer able to see the text being typed :( This worked perfectly fine until their last update, we do have a work around for this which is either to click the 'change view' button or use another browser that works perfectly fine :)

My apologies that you have experienced this issue and also that I don't have any better answers for you! but if you do have any further questions, please let me know! I will be happy to help :)

Best Wishes,

Lesley

photo
1

Hi Andrew,


Sorry for the delays on this. We've have a look at these issues, and it looks to be related to your browser cache, which actually ties in with what you were seeing when unchecking the 'cache' option.


I know it sounds like a cop out, though can you please refresh your browser cache and let me know how it goes?


I would be surprised if this doesn't resolve your issue.


Thanks,

David

photo
1

Hi David,

I had the same thought, and have not only tried refreshing the cache in the browser (and have reports from a few other users having the same issues in Chrome and Opera), but I have also performed a fresh install of Chrome on a virtual machine, and still have the same issues.

Regards,

Andrew

photo
1

Ok now I'm confused!


Do you think we would be able to hit your site directly from our machines over here?

If so, I'll move this to a private ticket so we can get login details.


Thanks,

David