Filter List Type "Popup" not working anymore

Renato Marcello dos Reis shared this question 2 days ago
In Progress

Hi everyone,

I'm having an issue that is currently being complained a lot for our clients.

The "popup" filter type is not working anymore. When we do add the filter in report creation, and select "Popup" as the filter type, after close the window, the filter type returns to his default value, which is selection list. If we do try to change this filter type in "Design", Yellowfin don't even let us change the option to "popup". The other options works as they should.

I'm using Yellowfin 9.4.1.

/471f7b73c32ab5f694a16b633822a954

Some of our filters, contains more than 1 thousand different values to choose. We cannot use filters without this option avaiable.

Can someone help me in this case?

Thanks in advance.

Regards,

Renato Marcello

Comments (3)

photo
1

Hey Renato,

I hope you are well!


I have just tested this out on my end, on version 9.4.1 and the pop up selection is working as expected -

f541c74db02e8d011444c785ab4a3964


9afb591d436daf0b2e2f9ba9e02e0ffb


Did this start happening after upgrading your yellowfin?

Or do you have any other settings applied that may affect this?


Let me know, so we can look further into it :)


Best Wishes,

Lesley

photo
1

Hi Lesley,

I hope all is well with you.

This wasn't happening on 8.0.7 version which was the last build in our clients. I have an enviroment with this version installed from where I've tested.

After upgrade to 9.4.1, this behaviour started.

What kind of configuration can prevent this option to be working as it should? Do you have any idea?

The only thing I can think of is "Access Filters". But I can't imagine how can this thing being related.

I hope you can help me find whats going on on my side.

One last thing to add, is that we have 3 clients with the same problem.

EDIT: I also tried to test this behaviour on other browsers, but still nothing changed. Most of our clients use Firefox or Google Chrome. To make sure it wasn't nothing related, I tested on Edge too. All of then shows the same behaviour.

Thanks in advance.

Regards,

Renato Marcello

photo
1

Hi Lesley,

I'm trying to make sure I've running all the possibilities here, so I did some more tests. Sadly, none of then seems to be the solution we're looking for.

1. I've dropped all my custom CSS and Images to return to Yellowfin default appereance.

2. I've tried to use some different versions of JRE. Currently I'm using 8.0.281, however, I've testes on older versions to see if this was the problem.

3. I've tried to upgrade Yellowfin to 9.4.2 on a test enviroment.

None of the options above have seem to change anything, so I'm not sure what more can be done to Find the solution.

I also tried to search in log files to see if there's any message who can help us understand whats going on, but there's no event raised in log files when we do click to change the filter type. I even tried to see if the Console from Web Browser could show some error message after the filter type change, but also, nothing was shown there.

I'm running out of ideas of what to do so I can understand this issue.

I hope all this info can be of any help to find the solution.

Thanks a lot,

Renato Marcello