Data export options on report not clickable

Sam shared this question 11 days ago
In Progress

I have a report embedded in a webpage for the purpose of providing users a download option. I have gotten the format options to pop up when I click "Export" in testing, but then they're not clickable. I can highlight their text but nothing happens when I click on them. Can you advise? Here's how it looks:

/7268f1b0f2e2dec41072c12caf809275

Sam

Comments (2)

photo
1

Hi Sam,


Apologies for the delay.


I have tried to embed a report and tried exporting it- everything seems to work fine.

Could you please let me know if there are any errors in the browser console? And also share the Network traffic after clicking on the format(csv/pdf/text) to be exported as in the video attached. That can be accessed from Browser Developer tools -->Network

And is it the case with only one particular report? or all the reports embedded behave the same?


Best Regards,

Deepak

photo
1

Here's what I get on the Network traffic when I click the Export (down arrow), then CSV format choice:

/35e76c4fc410b3d8eba90f5c196fb750

For the other reports in this same dashboard, nothing happens when I click the format (CSV or Excel) button for them either.

These are the console errors that appear as the container page with the dashboard loads:

/fde3c837d3cb876db872c9264654258e

I don't know that they're related but I'm asking a colleague for one thing to be changed that might address them. No additional console errors when I try to export the report.

To be clear, I have a report inside a dashboard embedded in a webpage - maybe one more layer of container than you have.